Bug 1023314 - Problems with entering JDK path for quickstarts on MAC OS
Problems with entering JDK path for quickstarts on MAC OS
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Mac OS
unspecified Severity medium
: ER7
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 03:56 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-25 03:56:47 EDT
Description of problem:
 I run into few problems during installation of quickstarts on MAC OS. Running GUI installation, I am able to enter any (even folder without JDK which is also wrong) folder as valid JDK target, on the other hand, running -console installation, I am unable to enter any JDK path. Also, for GUI installation default JDK path points to /Applications/EAP-6.2.0. In -console installation the path is empty.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER6

How reproducible:
 Always

Steps to Reproduce:
 1. Run -console installer
 2. Choose to install quickstarts
 3. Try to enter valid JDK path 

Actual results:
 "Path $PATH is not valid" message is shown.

Expected results:
 User is able to enter valid JDK path.

Additional info:
 Is there any use for JDK path selected by user? If not, I would consider removing this screen and move the message with JDK requirements to previous (Quickstarts screen).
Comment 1 Thomas Hauser 2013-10-25 09:25:21 EDT
This is almost certainly a bug in IzPack, in the code that is locating the JDK. 

The only use for this panel is to ensure that the user has a JDK available (one cannot build quickstarts without one.) 

I am not against removing the panel moving forward.
Comment 2 Francisco Canas 2013-10-25 11:01:53 EDT
It is an IzPack issue, but a complicated one:
The JDK validation code searches for a lib/tools.jar file in the user provided JDK path. However, mac os x uses their own JDK which specifically does *not* contain a tools.jar (see second bullet point in link):

https://developer.apple.com/library/mac/documentation/java/conceptual/java14development/02-javadevtools/javadevtools.html

The GUI version of izpack specifically ignores the tools.jar check if we you are on OSX, which is why you can enter pretty much any dir even if no JDK is present in it. However, the console does not ignore this check and since tools.jar is not present, -console should not detect any path as 'valid'.

For now I have removed the 'tools.jar' check from the -console installer in the case of mac OSX so that the user can continue console installation when they select quickstarts. But I agree that removing this screen entirely might be better in the long run.

http://git.app.eng.bos.redhat.com/izpack.git/commit/?id=1421d6849198387e75c2a21e4e3a9dff2a4950e5
Comment 3 Petr Kremensky 2013-10-30 04:16:42 EDT
I believe, we can remove this panel as I've seen similar issues also on some of Solaris hosts. I'll create new BZ request for this.
Comment 4 Petr Kremensky 2013-11-04 03:33:27 EST
Verified on EAP 6.2.0.ER7 installer.

Note You need to log in before you can comment on or make changes to this bug.