Bug 1023330 - [RHEVM][webadmin] New Data Center "Guide Me" does not reflect hosts presence
[RHEVM][webadmin] New Data Center "Guide Me" does not reflect hosts presence
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.4.0
Assigned To: Ravi Nori
Martin Pavlik
infra
: Reopened
: 1057115 (view as bug list)
Depends On:
Blocks: rhev3.4beta 1142926
  Show dependency treegraph
 
Reported: 2013-10-25 04:22 EDT by Martin Pavlik
Modified: 2016-02-10 14:20 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-24 16:31:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot 1 (188.25 KB, image/png)
2013-10-25 04:22 EDT, Martin Pavlik
no flags Details
screenshot 2 (175.63 KB, image/png)
2013-10-25 04:22 EDT, Martin Pavlik
no flags Details
screenshot 3 (175.36 KB, image/png)
2013-10-25 04:23 EDT, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 23816 None None None Never
oVirt gerrit 24833 None None None Never

  None (edit)
Description Martin Pavlik 2013-10-25 04:22:28 EDT
Created attachment 816041 [details]
screenshot 1

Description of problem:

if user goes via

Data Centers -> New (fill in name, click OK) -> Configure Cluster (fill in: name, CPU name, click OK) -> Configure Host (fill in: Name, address, password, click OK) see screenshot 1

user ends up back in dialog which offers him to configure host under "There are still unconfigured entities:"

configure host button should move under optional actions (we already have a host and dialog statement "There are still unconfigured entities:" is not valid any more for the cluster)

moreover change mentioned above would make RHEVM behavior consistent with path
Clusters -> New -> Configure Host (see screenshot 2) (fill in: Name, address, password, click OK)
which puts "add another host" button under optional actions (see screenshot 3)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.28.beta1.el6ev 

How reproducible:
100%

Steps to Reproduce:
see description

Actual results:
button for adding hosts does not move under optional actions after adding host to cluster in New Data Center guide me dialog

Expected results:
button for adding hosts moved under optional actions after adding host to cluster in New Data Center guide me dialog


Additional info:
Comment 1 Martin Pavlik 2013-10-25 04:22:49 EDT
Created attachment 816042 [details]
screenshot 2
Comment 2 Martin Pavlik 2013-10-25 04:23:29 EDT
Created attachment 816043 [details]
screenshot 3
Comment 3 Barak 2013-10-27 08:36:08 EDT
I don't think this is a bug,
Arthur ?
Comment 4 Arthur Berezin 2014-01-23 19:17:08 EST
Is bug is in the flow if "Guide me". Should this be under UX ?
Comment 5 Einav Cohen 2014-01-24 16:31:03 EST
(In reply to Arthur Berezin from comment #4)
> Is bug is in the flow if "Guide me". Should this be under UX ?

this bug is in the flow of the Data-Center "Guide Me" which is under the 'infra' team domain of responsibility. 

in any case - this is a duplicate of bug 1057115, please see bug 1057115 comment #2 for the needed changes.

*** This bug has been marked as a duplicate of bug 1057115 ***
Comment 6 Einav Cohen 2014-01-24 16:32:03 EST
closed on duplicate of an ovirt BZ by mistake, not sure that I should do that - re-opening. 
adding to the See Also section instead.
Comment 7 Ravi Nori 2014-02-20 16:45:36 EST
*** Bug 1057115 has been marked as a duplicate of this bug. ***
Comment 8 Martin Pavlik 2014-03-11 03:52:40 EDT
works in av 2.1

button for adding hosts moved under optional actions after adding host to cluster in New Data Center guide me dialog
Comment 9 Itamar Heim 2014-06-12 10:07:07 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.