Bug 1023331 - Cannot connect to IMAP4 server using IMAPS protocol
Cannot connect to IMAP4 server using IMAPS protocol
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
18
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 04:25 EDT by Sjoerd Mullender
Modified: 2013-10-27 06:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-26 05:34:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sjoerd Mullender 2013-10-25 04:25:53 EDT
Description of problem:
Most likely since the update of the openssl package to openssl-1.0.1e-28.fc18.x86_64 I cannot connect to some IMAP servers anymore using IMAPS.
This is true both for Python2 and Python3 and both in Fedora 18 and 19, although the Python3 stack trace is different.

Version-Release number of selected component (if applicable):
On Fedora 18:
openssl-1.0.1e-28.fc18.x86_64
python-2.7.3-13.fc18.x86_64
python3-3.3.0-1.fc18.x86_64
On Fedora 19:
openssl-1.0.1e-28.fc19.x86_64
python-2.7.5-8.fc19.x86_64
python3-3.3.2-6.fc19.x86_64

How reproducible:
100% (depending on server)

Steps to Reproduce:
1.python -c 'import imaplib; m = imaplib.IMAP4_SSL(host="zimap.cwi.nl")'
2.
3.

Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib64/python2.7/imaplib.py", line 1148, in __init__
    IMAP4.__init__(self, host, port)
  File "/usr/lib64/python2.7/imaplib.py", line 163, in __init__
    self.open(host, port)
  File "/usr/lib64/python2.7/imaplib.py", line 1160, in open
    self.sslobj = ssl.wrap_socket(self.sock, self.keyfile, self.certfile)
  File "/usr/lib64/python2.7/ssl.py", line 381, in wrap_socket
    ciphers=ciphers)
  File "/usr/lib64/python2.7/ssl.py", line 143, in __init__
    self.do_handshake()
  File "/usr/lib64/python2.7/ssl.py", line 305, in do_handshake
    self._sslobj.do_handshake()
ssl.SSLError: [Errno 1] _ssl.c:504: error:100AE081:elliptic curve routines:EC_GROUP_new_by_curve_name:unknown group


Expected results:
No traceback.

Additional info:
I suspect this is related to bug 1019390.
Comment 1 Sjoerd Mullender 2013-10-26 05:34:32 EDT
Fixed by updating to openssl-1.0.1e-29.

Note You need to log in before you can comment on or make changes to this bug.