Bug 1023335 - [RFE] pulp allows corrupt rpms to be pushed into repos
[RFE] pulp allows corrupt rpms to be pushed into repos
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.2
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
pulp-qe-list
: FutureFeature, Reopened, Triaged
: 1029085 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 04:27 EDT by Petter Hassberg
Modified: 2015-02-28 18:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-18 20:12:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 211 None None None Never

  None (edit)
Description Petter Hassberg 2013-10-25 04:27:32 EDT
Description of problem:
I create a repo, and push to it a corrupt rpm, which won't install.


Version-Release number of selected component (if applicable):
2.2.0-1

How reproducible:
always

Steps to Reproduce:

1. locate a corrupt rpm:
rpm -K /tmp/corruptrpm-1.0-1.noarch.rpm: RSA sha1 ((MD5) PGP) md5 NOT OK (MISSING KEYS: (MD5) PGP#f44e7eb7)

2. pulp-admin rpm repo create --repo-id test-repo2 --relative-url test-repo2

3. pulp-admin rpm repo uploads rpm -f /tmp/corruptrpm-1.0-1.noarch.rpm --repo-id=test-repo2
+----------------------------------------------------------------------+
                              Unit Upload
+----------------------------------------------------------------------+

Extracting necessary metadata for each request...
[==================================================] 100%
Analyzing: corruptrpm-1.0-1.noarch.rpm
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing: corruptrpm-1.0-1.noarch.rpm
... completed

Starting upload of selected units. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Uploading: corruptrpm-1.0-1.noarch.rpm
[==================================================] 100%
2729160/2729160 bytes
... completed

Importing into the repository...
... completed

Deleting the upload request...
... completed


Actual results:

Corrult rpm successfully pushed into pulp.

Expected results:

rpm upload should fail due to incorrect checksum


Additional info:
Comment 1 Petter Hassberg 2013-10-25 04:49:45 EDT
this was not a corrupt rpm after all.
Comment 2 Petter Hassberg 2013-11-11 09:49:22 EST
This also is applicable with actual corrupt rpm:s with sha1sum mismatch,.
Comment 3 Sayli Karmarkar 2013-11-13 11:56:04 EST
*** Bug 1029085 has been marked as a duplicate of this bug. ***
Comment 4 Brian Bouterse 2015-02-18 20:12:09 EST
Moved to https://pulp.plan.io/issues/211

Note You need to log in before you can comment on or make changes to this bug.