Bug 1023351 - Error : EXT4-fs error (device sda8): ext4_ext_search_left: inode #8126473: (comm db2sysc) ix (60672) != EXT_FIRST_INDEX (0) (depth 1)! leads to DB2 instance to crash
Error : EXT4-fs error (device sda8): ext4_ext_search_left: inode #8126473: (c...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
6.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Eric Sandeen
Eryu Guan
: ZStream
Depends On: 873201
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 05:05 EDT by Jan Kurik
Modified: 2013-11-07 10:56 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The resize2fs utility did not properly handle resizing of an ext4 file system to a smaller size. As a consequence, files containing many extents could become corrupted if they were moved during the resize process. With this update, resize2fs now maintains a consistent extent tree when moving files containing many extents, and such files no longer become corrupted in this scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 10:10:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 173543 None None None Never

  None (edit)
Description Jan Kurik 2013-10-25 05:05:03 EDT
This bug has been copied from bug #873201 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 6 Eryu Guan 2013-10-28 02:12:33 EDT
Test with /e2fsprogs/Regression/bz873201-resize2fs-shrink-move-extent-corruption, test passed, set to VERIFIED.
Comment 8 errata-xmlrpc 2013-11-05 10:10:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1502.html

Note You need to log in before you can comment on or make changes to this bug.