Bug 1023352 - Hammer CLI - several "os" commands fail
Hammer CLI - several "os" commands fail
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tomas Strachota
Corey Welton
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 05:08 EDT by Hayk Hovsepyan
Modified: 2016-04-22 12:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 3352 None None None 2016-04-22 12:06 EDT

  None (edit)
Description Hayk Hovsepyan 2013-10-25 05:08:14 EDT
Description of problem:
Here are several "os" commands that fail to execute:

"os info" and "os list" commands does not show result and shows this message "interning empty string".

"os add_configtemplate", "os remove_configtemplate", "os remove_architecture", "os add_architecture" commands show error "Error: uninitialized constant HammerCLIForeman::AssociatedCommand::ResourceInstance".
Comment 1 RHEL Product and Program Management 2013-10-25 05:37:55 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Dominic Cleal 2013-10-25 08:25:21 EDT
Already fixed in upstream hammer-cli.  Martin, could you please make a hammer-cli release?

The ResourceInstance error is different, please file another BZ referencing http://projects.theforeman.org/issues/3499.
Comment 4 Dominic Cleal 2013-10-25 09:04:55 EDT
Don't worry about the ResourceInstance error BZ, we've already got bug #1023071 for it.
Comment 5 Tomas Strachota 2013-10-29 15:59:31 EDT
New versions released and available in koji:
 	rubygem-hammer_cli-0.0.8
 	rubygem-hammer_cli_foreman-0.0.9
Comment 6 Martin Bacovsky 2013-10-30 03:33:38 EDT
Fixed assignment to tstrachota.
Comment 9 Corey Welton 2013-10-31 09:40:36 EDT
QA Verified Satellite-6.0.2-RHEL-6-20131030.0
Comment 12 Bryan Kearney 2014-04-24 13:10:35 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 13 Bryan Kearney 2014-04-24 13:11:44 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.