Bug 102336 - com.redhat.persistence.pdl.PDL.emitVersioned() is exceptionally slow
Summary: com.redhat.persistence.pdl.PDL.emitVersioned() is exceptionally slow
Status: CLOSED DUPLICATE of bug 101658
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: installation   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Vadim Nasardinov
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-13 22:44 UTC by Rafael H. Schloming
Modified: 2014-12-01 23:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rafael H. Schloming 2003-08-13 22:44:18 UTC
emitVersioned() seems to be taking around 4-5 seconds during initialization.
This is the bulk of the time taken by the persistence initializer. This is
probably also why generating DDL is very slow during full builds. We should see
a dramatic improvement in server startup time, ddl generation, and pdl
verification time if we can make this faster.

Comment 1 Vadim Nasardinov 2003-10-29 21:25:46 UTC

*** This bug has been marked as a duplicate of 101658 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.