Bug 1023384 - different error message when size is too small between clone from image and clone from volume [NEEDINFO]
different error message when size is too small between clone from image and c...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
x86_64 Linux
unspecified Severity low
: rc
: 5.0 (RHEL 7)
Assigned To: Flavio Percoco
Yogev Rabl
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 06:17 EDT by Dafna Ron
Modified: 2016-04-26 13:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.1-4.el6ost
Doc Type: Bug Fix
Doc Text:
In previous releases, if a source of a volume or image was larger than the destination, then cloning the source or image resulted in inconsistent errors, depending on the source type. This release applies several consistency fixes to the error messaging system of volume clones, as well as volume clones from: * images, * snapshots, and * other volumes In addition, with this release error messages now indicate the unit (for example, GB).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 11:30:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ddomingo: needinfo? (fpercoco)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1244609 None None None Never
OpenStack gerrit 68162 None None None Never

  None (edit)
Description Dafna Ron 2013-10-25 06:17:01 EDT
Description of problem:

I am working with gluster configured as cinder backend.
if I try to clone a volume from image when the new volume size is smaller than the image we get the following error:

[root@cougar06 ~(keystone_admin)]# cinder create 10 --image-id 0924d3a4-d163-4ae5-8f57-fb9f1912ee26 --display-name dafna_new

ERROR: Invalid input received: Image minDisk size 20 is larger than the volume size 10.

if I try to clone a volume from a volume when the new volume is smaller than the volume we clone from we get the following error:

[root@cougar06 ~(keystone_admin)]# cinder create 10 --source-volid c3b6cb41-d78d-420d-b64c-d5f3782f7772 --display-name new_clone

ERROR: Invalid input received: Clones currently disallowed when 10 < 20. They must be >= original volume size.

Version-Release number of selected component (if applicable):

openstack-cinder-2013.2-0.11.rc1.el6ost.noarch
python-cinder-2013.2-0.11.rc1.el6ost.noarch
python-cinderclient-1.0.6-1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create an image and a volume 
2. clone a volume from the image but give new volume size smaller than the image 
3. clone a volume from the volume but give a new volume size smaller than the src volume. 

Actual results:

we get different error messages 

Expected results:

we should get the same error messages 

Additional info:
Comment 2 Yogev Rabl 2014-06-25 08:51:24 EDT
verified in version:

openstack-cinder-2014.1-6.el7ost.noarch
python-cinder-2014.1-6.el7ost.noarch
python-cinderclient-1.0.9-1.el7ost.noarch
Comment 5 errata-xmlrpc 2014-07-08 11:30:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0852.html

Note You need to log in before you can comment on or make changes to this bug.