Bug 1023441 - infiniband test fails: can't log hardware via udev
infiniband test fails: can't log hardware via udev
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1052374
  Show dependency treegraph
 
Reported: 2013-10-25 08:38 EDT by Greg Nichols
Modified: 2014-04-03 09:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-03 09:58:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2013-10-25 08:38:34 EDT
Description of problem:

The infiniband test fails when it can't find the UDI to log hardware via udev.

<output>
<output name="Log Hardware Info" description="log hardware info from udev">
Warning: fail to get UDI
<summary>FAIL</summary>
</output>
<output name="Log Status" description="log infiniband status">
Infiniband device 'cxgb3_0' port 1 status:
	default gid:	 0007:4308:adf6:0000:0000:0000:0000:0000
	base lid:	 0x0
	sm lid:		 0x0
	state:		 4: ACTIVE
	phys state:	 0: <unknown>
	rate:		 20 Gb/sec (4X DDR)
	link_layer:	 Ethernet

Infiniband device 'cxgb3_0' port 2 status:
	default gid:	 0007:4308:adf7:0000:0000:0000:0000:0000
	base lid:	 0x0
	sm lid:		 0x0
	state:		 1: DOWN
	phys state:	 0: <unknown>
	rate:		 20 Gb/sec (4X DDR)
	link_layer:	 Ethernet

<summary>PASS</summary>
</output>
</output>

Version-Release number of selected component (if applicable):

hwcert-client 1.6.5-22

Additional info:

rdma-dev-08.lab.bos.redhat.com

Results file:

http://hwcert.boston.devel.redhat.com/hwcert/store/bbrock/PowerEdge/PowerEdge%20R415/x86_64/RHEL/6.5/hwcert-results-rdma-dev-08.lab.bos.redhat.com-20131025041412.xml.gz
Comment 1 Greg Nichols 2013-10-25 09:14:54 EDT
Looks like the infiniband device shows up in UDEV as:

<device device-bus="" product="cxgb3_0" udi="/devices/pci0000:00/0000:00:02.0/0000:01:00.0/infiniband/cxgb3_0" source="udev" device-class="">
      <property name="SUBSYSTEM">infiniband</property>
      <property name="UDEV_LOG">3</property>
      <property name="NAME">cxgb3_0</property>
      <property name="info.udi">/devices/pci0000:00/0000:00:02.0/0000:01:00.0/infiniband/cxgb3_0</property>
      <property name="DEVPATH">/devices/pci0000:00/0000:00:02.0/0000:01:00.0/infiniband/cxgb3_0</property>
    </device>

The test is planned based on PCI_CLASS, which doesn't appear.   Was this test manually planned?
Comment 2 Rob Landry 2013-10-25 16:21:09 EDT
Do we need to add subsystem infiniband as a plan target?
Comment 3 Greg Nichols 2013-10-25 16:23:49 EDT
We could.    Is this a supported configuration/RHEL release?
Comment 4 Brian Brock 2013-10-25 16:26:10 EDT
Yes, it was planned manually.  By default it wasn't selected.  File as a separate bug?
Comment 5 Greg Nichols 2013-10-25 16:32:30 EDT
No.  via Doug's comments, it seems like it's misconfigured?

> This is cxgb3 and it technically is an iWARP system.  You might need to
> modify your setup to work with it.
Comment 6 Greg Nichols 2014-04-03 09:58:06 EDT
(In reply to Greg Nichols from comment #5)
> No.  via Doug's comments, it seems like it's misconfigured?
> 
> > This is cxgb3 and it technically is an iWARP system.  You might need to
> > modify your setup to work with it.

Closing

Note You need to log in before you can comment on or make changes to this bug.