Bug 1023455 - [CodeChange][RFE] log-collector should use the same code used by the engine for parsing configuration
[CodeChange][RFE] log-collector should use the same code used by the engine f...
Status: CLOSED CURRENTRELEASE
Product: ovirt-log-collector
Classification: oVirt
Component: RFEs (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity low (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Douglas Schilling Landgraf
Pavel Novotny
: CodeChange, FutureFeature, Improvement
Depends On:
Blocks: 1456888
  Show dependency treegraph
 
Reported: 2013-10-25 09:09 EDT by Sandro Bonazzola
Modified: 2017-12-20 05:46 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:46:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
gklein: testing_plan_complete-
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 77246 master MERGED config: update ENGINE_DEFAULTS 2017-05-24 16:22 EDT
oVirt gerrit 78450 ovirt-log-collector-4.1 MERGED config: update ENGINE_DEFAULTS 2017-06-21 17:22 EDT

  None (edit)
Description Sandro Bonazzola 2013-10-25 09:09:05 EDT
rhevm-log-collector parse engine configuration using as default the content of
/usr/share/conf/engine.conf.defaults which doesn't exist.
The file in 3.2 was in /usr/share/ovirt-engine/conf/engine.conf.defaults and has been moved to /usr/share/ovirt-engine/services/ovirt-engine/ovirt-engine.conf in 3.3.

This error can't be detected just running it and don't have user impact because the content of the default file is not really useful for log-collector.
However it is better to use the same class for parsing conf files within all tools avoiding to be out of sync.
Comment 2 Red Hat Bugzilla Rules Engine 2017-05-24 16:55:28 EDT
This request has been proposed for two releases. This is invalid flag usage. The ovirt-future release flag has been cleared. If you wish to change the release flag, you must clear one release flag and then set the other release flag to ?.
Comment 3 Lukas Svaty 2017-09-04 06:40:26 EDT
CodeChange moving to VERIFIED
Comment 4 Sandro Bonazzola 2017-12-20 05:46:04 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.