Bug 1023463 - Server could not start when running with 32bit java on 64bit system
Server could not start when running with 32bit java on 64bit system
Status: CLOSED DUPLICATE of bug 1022620
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
Unspecified Windows
unspecified Severity high
: ER05
: JON 3.2.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-25 09:26 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 09:26:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-10-25 09:26:54 EDT
Description of problem:

Server could not start when running with 32bit java on 64bit system

Version-Release number of selected component (if applicable):
JON 3.2.ER4

How reproducible: always


Steps to Reproduce:
1. install ONLY 32b java on your system
2. install JON using rhqctl install
3. start JON server

Actual results:

JON server cannot start 

ERROR [org.jboss.as.ejb3.invocation] (pool-9-thread-1) JBAS014134: EJB Invocation failed on component StartupBean for method public abstract void org.rhq.enterprise.server.core.StartupLocal.init(): javax.ejb.EJBException: java.lang.RuntimeException: Startup failed: java.io.tmpdir 'C:\Windows\system32\config\systemprofile\AppData\Local\Temp' does not exist
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.handleExceptionInNoTx(CMTTxInterceptor.java:191) [jboss-as-ejb3-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]
        at org.jboss.as.ejb3.tx.CMTTxInterceptor.invokeInNoTx(CMTTxInterceptor.java:237) [jboss-as-ejb3-7.2.1.Final-redhat-10.jar:7.2.1.Final-redhat-10]

but C:\Windows\system32\config\systemprofile\AppData\Local\Temp exists. If you switch to 64b java, you'll not hit this issue.

Expected results:
JON server starts up

Additional info:
Comment 1 Jay Shaughnessy 2013-10-28 09:26:16 EDT
This is the same issue as bug 1022620, marking as duplicate.

*** This bug has been marked as a duplicate of bug 1022620 ***

Note You need to log in before you can comment on or make changes to this bug.