Bug 1023471 - Increase the saved random-seed to 4K
Summary: Increase the saved random-seed to 4K
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.5
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Jan Ščotka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-25 13:43 UTC by Steve Grubb
Modified: 2016-11-25 13:07 UTC (History)
3 users (show)

Fixed In Version: initscripts-9.03.41-1.el6
Doc Type: Bug Fix
Doc Text:
Due to updated crypto requirements, we have to increase the saved seed size from 512 bytes to 4096 bytes in /etc/rc.sysinit.
Clone Of:
Environment:
Last Closed: 2014-10-14 06:27:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1448 0 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2014-10-14 01:05:44 UTC

Description Steve Grubb 2013-10-25 13:43:37 UTC
Description of problem:
Due to updated crypto requirements, we need to increase the saved seed size from 512 bytes to 4096 bytes in /etc/rc.sysinit. The spec file also saves a seed during install and this needs bumping up also. This affects the current planned FIPS-140 certification.

Steps to Reproduce:
1. ls -l /var/lib/random-seed

Actual results:
512

Expected results:
4096

Comment 7 errata-xmlrpc 2014-10-14 06:27:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1448.html


Note You need to log in before you can comment on or make changes to this bug.