Bug 1023499 - Install error due incorrect parsing of multipath -l output
Install error due incorrect parsing of multipath -l output
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 3.5.0
Assigned To: Fabian Deutsch
Virtualization Bugs
node
: OtherQA
Depends On:
Blocks: rhevh-6.5.4 1123329
  Show dependency treegraph
 
Reported: 2013-10-25 10:40 EDT by Tomas Von Veschler
Modified: 2016-02-10 15:03 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously the installation could fail in specififc multipath setups due to weak parsing. This is now fixed by better multipath -l output parsing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-03 08:34:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Von Veschler 2013-10-25 10:40:35 EDT
Description of problem:

Customer multipath -l output is like:

3600d0230000000000e13955cc3757800 dm-1 WINSYS,SF2372
size=269G features='0' hwhandler='0' wp=rw
|-+- policy='round-robin 0' prio=1 status=active
| `- 6:0:0:0 sdb 8:16  active ready  running
`-+- policy='round-robin 0' prio=1 status=enabled
  `- 7:0:0:0 sdf 8:80  active ready  running

Looking at install.py from ovirtnode (http://gerrit.ovirt.org/gitweb?p=ovirt-node.git;a=blob;f=src/ovirtnode/install.py;h=cf8ff33f17b0cf202329d0e346e75ee395b83bf5;hb=HEAD), line 522/523:

grub_disk_cmd = "multipath -l \"" + self.disk + \
                                "\" | awk '/ active / {print $3}' | head -n1"

The right column for sdb device would be the 4th and it's looking for the 3rd ({print $3}) instead. For device sdf or single group of devices the parsing is right. 

Version-Release number of selected component (if applicable):

rhev-h from RHEV 3.2

How reproducible:

always

Actual results:

Unable to install RHEV-H

Additional info:

HP Hardware
Comment 2 RHEL Product and Program Management 2013-10-31 07:06:49 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 haiyang,dong 2013-11-01 03:46:40 EDT
Seems Fabian's patch fixed this issue:
http://gerrit.ovirt.org/#/c/20558/
Comment 4 haiyang,dong 2013-11-01 03:52:56 EDT
virt-qa has no specififc multipath device that could multipath -l output info like this:
| `- 6:0:0:0 sdb 8:16  active ready  running

so need the reporter to verify this bug after the patch is merged into offical build.
Comment 8 Tomas Von Veschler 2013-11-20 13:44:07 EST
I can confirm a RHEV-H build with the patch included fixes the problem. Thanks!
Comment 10 Cheryn Tan 2014-01-08 00:36:35 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 21 Ying Cui 2014-09-03 06:01:25 EDT
Re-testing on QE env. again according to comment 20. Thanks.

Note You need to log in before you can comment on or make changes to this bug.