Bug 1023543 - xmvn tries to install package even though %mvn_package foo __noinstall
xmvn tries to install package even though %mvn_package foo __noinstall
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 13:27 EDT by Severin Gehwolf
Modified: 2013-11-05 13:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 13:02:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Severin Gehwolf 2013-10-25 13:27:30 EDT
Description of problem:
Thermostat fails to build in rawhide due to xmvn installer mojo trying to install a __noinstall artifact.

Version-Release number of selected component (if applicable):
Version available in rawhide.

How reproducible:
Always in rawhide.

Steps to Reproduce:
1. fedpkg clone thermostat
2. look at the spec file which has %mvn_package com.redhat.thermostat:thermostat-distribution __noinstall
3. fedpkg build

Actual results:
Build fails with FileNotFoundException of the thermostat-distribution jar file.

Expected results:
Don't try to find/install thermostat-distribution file.

Here is an example build log:
http://kojipkgs.fedoraproject.org//work/tasks/8836/6098836/build.log

This is a task which I expect fails, once it's finished:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6099482

Note that f20 builds work fine with the same spec file. Also keep in mind that the spec file in master will change soon in master due to an upcoming thermostat upgrade.
Comment 1 Mikolaj Izdebski 2013-11-05 11:33:19 EST
thermostat has a complex structure and a very complex spec file.
This makes it difficult for me to investigate what is going on.
Can you provide a simple reproducer?
Comment 2 Severin Gehwolf 2013-11-05 11:59:51 EST
I think this doesn't occur any longer in rawhide. I'll get back to you if it does still fail, but a scratch build passed today so it might as well be already fixed.
Comment 3 Severin Gehwolf 2013-11-05 13:02:02 EST
Seems fixed. Closing.
Comment 4 Severin Gehwolf 2013-11-05 13:02:51 EST
For reference a passing thermostat rawhide build using xmvn: http://koji.fedoraproject.org/koji/taskinfo?taskID=6140584

Note You need to log in before you can comment on or make changes to this bug.