Bug 1023549 - [ToolTips] Hoverable tooltips should have a "hover intent" delay
[ToolTips] Hoverable tooltips should have a "hover intent" delay
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
All Unspecified
unspecified Severity low
: ---
: 3.6.0
Assigned To: Greg Sheremeta
Lukas Svaty
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 13:47 EDT by Greg Sheremeta
Modified: 2016-02-10 14:45 EST (History)
6 users (show)

See Also:
Fixed In Version: ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:38:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 37935 master MERGED userportal, webadmin: convert all grids (Cells) to PatternFly tooltips Never

  None (edit)
Description Greg Sheremeta 2013-10-25 13:47:45 EDT
Description of problem:
Hoverable tooltips should have a "hover intent" delay before showing the tooltip. When hovering over a fancy tooltip in WebAdmin, the tooltip shows instantly. This is jarring to the eye, and inconstant with the old HTML status based tooltips, which delay a second or two before showing the tooltip.

For an example of hover intent, see: http://cherne.net/brian/resources/jquery.hoverIntent.html
Notice how you can pass the mouse quickly through the intent-capable row and nothing happens. Once you rest the mouse, the event is fired.

Version-Release number of selected component (if applicable):
N/A, master

How reproducible:
always

Steps to Reproduce:
1. login to WebAdmin
2. click on the Data Centers tab
3. hover over the status icon for a data center.

Actual results:
The fancy tooltip pops up instantly.

Expected results:
The fancy tooltip should wait a second before popping up.
A user should be able to run the mouse very quickly over an icon without popping up a tooltip. Once the mouse rests for a second, the tooltip should show. 

Additional info:
Comment 1 Itamar Heim 2014-01-12 03:42:08 EST
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.
Comment 2 Sandro Bonazzola 2014-03-04 04:26:45 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 3 Sandro Bonazzola 2014-05-08 09:55:38 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 4 Einav Cohen 2014-05-29 13:57:26 EDT
as Greg suggested, let's look into patternfly/bootstrap tooltips which seem to support a '(data-)delay' option:
https://www.patternfly.org/widgets/#tooltip
http://getbootstrap.com/javascript/#tooltips
Comment 5 Lukas Svaty 2015-09-15 10:41:40 EDT
rhevm-webadmin-portal-3.6.0-0.13.master.el6.noarch
Comment 6 Sandro Bonazzola 2015-11-04 06:38:02 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.