Bug 1023556 - Blivet.copy does not update parted disk refs for partitions on hidden disks
Blivet.copy does not update parted disk refs for partitions on hidden disks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20BetaBlocker 1023583
  Show dependency treegraph
 
Reported: 2013-10-25 14:10 EDT by David Lehman
Modified: 2013-11-07 00:04 EST (History)
7 users (show)

See Also:
Fixed In Version: python-blivet-0.23.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1023583 (view as bug list)
Environment:
Last Closed: 2013-11-07 00:04:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-10-25 14:10:05 EDT
Description of problem:
During a deep-copy of blivet we have to update the parted.Partitions so they are associated with the same instance of parted.Disk that is in the newly copied disk's format instance. We failed to perform the same update on partitions that reside on hidden disks (eg: disks not selected during OS installation).

Version-Release number of selected component (if applicable):
python-blivet-0.24-1

How reproducible:
Always (using anaconda)

Steps to Reproduce:
1. select one of two full disks, choose custom, clear disk, autopart, save
2. revisit storage, select both disks, choose reclaim, delete all, reclaim

Actual results:
traceback from pyparted saying partition (on previously hidden disk) is not part of the disk it is being removed from

Expected results:
successful clearing and reinitialization, then autopart, of both disks

Additional info:
Comment 1 Mike Ruckman 2013-10-28 13:02:29 EDT
Discussed in 2013-10-28 Blocker Review meeting [1]. Voted as an AcceptedBlocker as it violates the following F20 beta release criterion: "When using the custom partitioning flow, the installer must be able to ... Correctly interpret, and modify as described below, any disk with a valid ms-dos or gpt disk label and partition table containing ext4 partitions, LVM and/or btrfs volumes, and/or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions" [2] 

[1] http://meetbot.fedoraproject.org/meetbot/meetbot/fedora-blocker-review/2013-10-28/
[2] http://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning
Comment 2 Fedora Update System 2013-10-30 20:39:02 EDT
python-blivet-0.23.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-blivet-0.23.3-1.fc20
Comment 3 Fedora Update System 2013-10-31 13:39:11 EDT
Package python-blivet-0.23.3-1.fc20, anaconda-20.25.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.23.3-1.fc20 anaconda-20.25.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20387/anaconda-20.25.5-1.fc20,python-blivet-0.23.3-1.fc20
then log in and leave karma (feedback).
Comment 4 Kamil Páral 2013-11-04 07:10:04 EST
F20 Beta TC6 contained python-blivet-0.23.2 and I can't reproduce this issue with it. Comment 0 says the affected version was _0.24_. Comment 3 says it is fixed in _0.23.3_ (Beta RC2). I can't reproduce the issue with RC2 either.

David, can you clear up the version numbers confusion?
Comment 5 David Lehman 2013-11-04 10:22:55 EST
blivet was branched for f20 after 0.23, so 0.23.3 is not "older" than 0.24 necessarily. 0.23.3 was built on 30 Oct while 0.24 was built on 16 Oct.
Comment 6 Kamil Páral 2013-11-04 11:15:52 EST
Does blivet follow the same weird branch policy as anaconda? It that case I understand the versioning scheme - 0.24 is master and 0.23.x is blivet branch during Beta freeze. But I don't understand why this bug was proposed as a blocker against a blivet version that was not part of any previous or current or future Beta compose.

Nevertheless, since I can't trigger the issue with TC6, we probably need you, David, to verify the fix with RC2. Can you please do that? Thanks.
Comment 7 David Lehman 2013-11-04 11:41:35 EST
(In reply to Kamil Páral from comment #6)
> Does blivet follow the same weird branch policy as anaconda?

What is weird about it? Would you prefer that we stop all long-term work for the 8 months of each year that fedora is in some kind of freeze? Or is there some other branch policy that you have in mind?

When you tried to reproduce did you make sure that each disk initially contained at least one existing partition?
Comment 8 Kamil Páral 2013-11-04 11:52:06 EST
Originally I forget to fill one of the disks. Now I was able to reproduce the crash with TC6 and verify the fix with RC2.
Comment 9 Fedora Update System 2013-11-07 00:04:10 EST
python-blivet-0.23.3-1.fc20, anaconda-20.25.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.