Bug 1023600 - Cannot add rockmongo-1.1 to a scalable nodejs-0.10 app with mongodb-2.2 cartridge
Cannot add rockmongo-1.1 to a scalable nodejs-0.10 app with mongodb-2.2 cartr...
Status: CLOSED UPSTREAM
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All Mac OS
unspecified Severity medium
: ---
: ---
Assigned To: Timothy Williams
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 18:12 EDT by Petar Bojinov
Modified: 2016-03-09 15:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 18:16:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petar Bojinov 2013-10-25 18:12:01 EDT
Description of problem:
Cannot add rockmongo-1.1 to a scalable nodejs-0.10 app using mongodb-2.2 cartridge

Version-Release number of selected component (if applicable):
rockmongo-1.1

How reproducible:
Create a scalable app with a mongodb cartridge then try to add rockmongo to the app. Can be easily reproduced with a new scaled app.


Steps to Reproduce:
1. rhc create-app helloscale nodejs-0.10 -s
2. rhc scale-cartridge nodejs-0.10 -a helloscale --min 1 --max -1
3. rhc cartridge add mongodb-2.2 -a helloscale
4. rhc cartridge add rockmongo-1.1 -a helloscale

Actual results:
Adding rockmongo-1.1 to application 'helloscale' ... rockmongo-1.1 cannot be embedded in scalable app 'helloscale'.

Expected results:
Be able to add rockmongo to scaled app.

Additional info:
My understanding is the mongo instance isn't scaled so rockmongo should be able to  be added to scaled app instance.
Comment 1 Jhon Honce 2013-10-25 18:16:31 EDT
Status of this enhancement request can be tracked here: https://trello.com/c/9ZSjRz9y
Comment 2 Roger Williamson 2016-03-09 11:18:53 EST
(In reply to Jhon Honce from comment #1)
> Status of this enhancement request can be tracked here:
> https://trello.com/c/9ZSjRz9y

The Trello card is private.  How is the public supposed to follow the progress of this issue?
Comment 3 Brenton Leanhardt 2016-03-09 12:57:13 EST
Hi Roger,

I don't think that the card is private I suspect it's simply been archived since this issue was filed a few years ago.  I'm passing this to the team that maintains our 2.x codebase so they can follow up in case any improvements have been made to the cartridges involved.  I would guess that this point we aren't adding new features.  They'll know for sure though.
Comment 4 Timothy Williams 2016-03-09 15:26:53 EST
For what its worth, the error reported can still be reproduced.

This isn't specific to the rockmongo cartridge. The phpmyadmin cartridge behaves the same way when added to a scaled php/mysql application:

  rhc cartridge-add phpmyadmin -a phpmytest
  Using phpmyadmin-4 (phpMyAdmin 4.0) for 'phpmyadmin'
  Adding phpmyadmin-4 to application 'phpmytest' ... phpmyadmin-4 cannot be embedded in scalable app 'phpmytest'.

Due to cartridge architecture, it is not possible currently for these cartridges to be co-located with the database cartridge in a scaled application.

It is also not likely, due to the high estimate of work involved, that this feature will be added for these cartridges.

I will leave this bug in CLOSED state. This issue is already solved with origin, the latest openshift codebase:

  https://github.com/openshift/origin

Note You need to log in before you can comment on or make changes to this bug.