Bug 102361 - empty log messages with continue
Summary: empty log messages with continue
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-14 14:54 UTC by Fergal Daly
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-08 12:00:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fergal Daly 2003-08-14 14:54:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
when checking in files in multiple directories, the log message is lost after
the first set of files. That is if you enter "!" or "c" to reuse the message for
all check ins then all the following checkins then only the first set of files
will get the log message, the rest will have

*** empty log message ***


Version-Release number of selected component (if applicable):
cvs-1.11.2-10

How reproducible:
Always

Steps to Reproduce:
run the following commands and when you save the first log message do "!" or "c"
to reuse the message

mkdir cvtest
cd cvtest/
cvs import -m "just a test" cvtest f s
cvs co cvtest
cd cvtest/
mkdir d
echo > a
echo > d/a
cvs add a d d/a  
cvs ci
cvs log


Actual Results:  cvs log: Logging .

RCS file: /home/fergal/my/cvs/cvtest/a,v
Working file: a
head: 1.1
branch:
locks: strict
access list:
symbolic names:
keyword substitution: kv
total revisions: 1;     selected revisions: 1
description:
----------------------------
revision 1.1
date: 2003/08/14 14:40:45;  author: fdaly;  state: Exp;
hello
=============================================================================
cvs log: Logging d

RCS file: /home/fergal/my/cvs/cvtest/d/a,v
Working file: d/a
head: 1.1
branch:
locks: strict
access list:
symbolic names:
keyword substitution: kv
total revisions: 1;     selected revisions: 1
description:
----------------------------
revision 1.1
date: 2003/08/14 14:40:47;  author: fdaly;  state: Exp;
*** empty log message ***
=============================================================================


Expected Results:  *** empty log message *** shoud say 

hello

Additional info:

Comment 1 Fergal Daly 2004-08-03 19:50:27 UTC
Since this has finally been assigned to someone, I should point out
that  it was fixed in later releases.


Note You need to log in before you can comment on or make changes to this bug.