Bug 1023614 - No logging to files
No logging to files
Status: CLOSED UPSTREAM
Product: RDO
Classification: Community
Component: openstack-glance (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jon Bernard
Dafna Ron
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-25 22:43 EDT by Pete Zaitcev
Modified: 2016-04-26 18:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-08 17:24:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glance-registry.conf (3.31 KB, text/plain)
2013-10-30 16:56 EDT, Pete Zaitcev
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1248292 None None None Never
OpenStack gerrit 55312 None None None Never

  None (edit)
Description Pete Zaitcev 2013-10-25 22:43:56 EDT
Description of problem:

Glance does not log anything to configured logfiles

Version-Release number of selected component (if applicable):

openstack-glance-2013.2-1.el6.noarch
 ("yum info" says it came from "opentack-havana" repo)

How reproducible:

Synchronous

Steps to Reproduce:
1. yum install openstack-glance
2. grep log_file /etc/glance-*.conf
   verify that log_file is commented and points /var/log/glance/FOO.log
3. Verify that /var/log/glance is owned by glance (should be ok)
4. . keystonerc
5. glance index (should succeed)
6. ls -l /var/log/glance/registry.log  -- missing or empty

Actual results:

No logging at all

Expected results:

Logging

Additional info:

If I uncomment the log_file statement, log is written properly.
Therefore, I conclude that the default in the code is incorrect.
Comment 1 Flavio Percoco 2013-10-30 14:20:17 EDT
(In reply to Pete Zaitcev from comment #0)
> Synchronous
> 
> Steps to Reproduce:
> 1. yum install openstack-glance
> 2. grep log_file /etc/glance-*.conf
>    verify that log_file is commented and points /var/log/glance/FOO.log

You meant not commented, right?

What's the value of verbose and debug ?

Could you please attach the config file to the bug?
Comment 2 Pete Zaitcev 2013-10-30 15:47:44 EDT
(In reply to Flavio Percoco from comment #1)

> >    verify that log_file is commented and points /var/log/glance/FOO.log
> 
> You meant not commented, right?

No, I mean commented, as stated. If log_file is uncommented, then logging
works. Step 2 verifies that openstack-glance is installed as expected.
Comment 3 Pete Zaitcev 2013-10-30 16:56:12 EDT
Created attachment 817635 [details]
glance-registry.conf
Comment 4 Jon Bernard 2013-11-04 16:49:18 EST
From what I'm reading, if the 'log_file' directive is omitted or commented out, then log messages are sent to stdout.  It sounds like what is described in the bug report is the intended behaviour.  Am I not understanding this correctly?
Comment 5 Pete Zaitcev 2013-11-04 19:32:29 EST
One way or the other, the comment in the stock glance-foo.conf has to be
made to match the reality. If the default is stderr, then fix the comment
to reflect that fact.
Comment 6 Jon Bernard 2013-11-05 14:28:02 EST
I submitted a patch upstream, currently waiting on review: https://review.openstack.org/#/c/55312/.

If that gets accepted I'll go through the backport process.

Note You need to log in before you can comment on or make changes to this bug.