This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1023621 - can"t change the default application
can"t change the default application
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-file-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 03:35 EDT by cornel panceac
Modified: 2013-10-26 15:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-26 12:24:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2013-10-26 03:35:17 EDT
Description of problem:
Choosing "Open with another application" and having selected "Set this as default" (strings were apoximately translated from Romanian, may be not precisely so), the new application (vlc, for video files) is not set as the default, the files still open with xine.


Version-Release number of selected component (if applicable):
$ rpm -q mate-file-manager
mate-file-manager-1.6.3-0.7.gitbf47018.fc19.i686



How reproducible:
always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This is probably applicable to other mime types, like opening .iso files with gedit ...
Comment 1 Wolfgang Ulbrich 2013-10-26 06:25:30 EDT
I can't confirm this on my f19 installation, tested with a .mkv file.
If i choose another player with 'open with/another application' and 'set this as default' is checked, this file open with the new default if i double click to open it. Tested with several players.

Another way to set this is to use the properties dialog of the file.
Here you can set the default application too.

For a general setting which affected all kinds of video files you can use
'mate-default-applications-properties'
Comment 2 cornel panceac 2013-10-26 07:40:56 EDT
interesting things happend. i've opened mate-default-applications-properties and found that the default vidoe player is kde's plasma media center. form now on, all videos opened with it, instead of the old default (xine). another change is that now i can select a different media player under "Properties" (there"s no set as default button, though). however, if i choose vlc there as the default, after closing "Properties", plasma media center is still the default. next, if i choos vlc under 'mate-default-applications-properties', then vlc becomes the default.
Comment 3 Wolfgang Ulbrich 2013-10-26 12:24:09 EDT
I'm pretty shure this issue happend because you've already kde installed.
Here on installation with MATE/cinnamon/gnome i don't see this issue.
I hope you agree that this isn't a MATE issue.
Comment 4 cornel panceac 2013-10-26 15:09:22 EDT
well, in the perfect universe this should not happen. On the other hand, since there is a workaround for it, that'S enough for me :)

i have indeed kde installed, but since i fail to see the way kde messes with mate functionality, i can not either confirm or deny that"S the reason things are not the way i exepcted them to be.

thank you for support, Wolfgang.

Note You need to log in before you can comment on or make changes to this bug.