Bug 1023625 - scl.attr screws up %__pkconfig_{provides,path} macros when building for non-SCL
scl.attr screws up %__pkconfig_{provides,path} macros when building for non-SCL
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scl-utils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1031051 1023628 1031072
  Show dependency treegraph
 
Reported: 2013-10-26 05:05 EDT by Nils Philippsen
Modified: 2014-03-01 09:13 EST (History)
6 users (show)

See Also:
Fixed In Version: scl-utils-20140127-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1023628 (view as bug list)
Environment:
Last Closed: 2014-03-01 09:06:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2013-10-26 05:05:11 EDT
Description of problem:
If scl-utils-build is installed, -devel packages which contain *.pc files don't get dependencies on /usr/bin/pkg-config. The definitions of %__pkgconfig_provides/%__pkgconfig_path are wrong which makes RPM not recognize that the corresponding requires/provides script needs to be run

Version-Release number of selected component (if applicable):
scl-utils-build-20130529-2.fc19.x86_64

How reproducible:
Reproducible

Steps to Reproduce:
1. With and without scl-utils-build installed, run "rpm --eval %__pkgconfig_provides"
2. Check for differences

Actual results:
nils@gibraltar:~> rpm --eval %__pkgconfig_provides
/usr/lib/rpm/scldeps.sh --provides %{scl}
nils@gibraltar:~> rpm --eval %__pkgconfig_path


Expected results:
nils@gibraltar:~> rpm --eval %__pkgconfig_provides
/usr/lib/rpm/pkgconfigdeps.sh --provides
nils@gibraltar:~> rpm --eval %__pkgconfig_path
^((/usr/lib64|/usr/share)/pkgconfig/.*.pc|/usr/bin/pkg-config)$

Additional info:
SCL should probably just use its own macros for this instead of attempting to overwrite existing ones.
Comment 1 Vít Ondruch 2013-11-14 05:31:35 EST
(In reply to Nils Philippsen from comment #0)
> Additional info:
> SCL should probably just use its own macros for this instead of attempting
> to overwrite existing ones.

I think it is just copy/paste error. Actually RPM documentation [1] speaks clearly at this point: "NAME needs to be replaced by the name choosen for the file attribute and needs to be the same as the file name of the macro file itself (without the .attr suffix)".

RPM is to blame here as well, since it should be reported at least IMO.


[1] http://rpm.org/wiki/PackagerDocs/DependencyGenerator
Comment 2 Vít Ondruch 2013-11-14 05:37:57 EST
Actually, I'd like to know what Panu thinks about it, if RPM can be improved in some meaningful way.
Comment 3 Panu Matilainen 2013-11-14 06:30:59 EST
Yes rpm should enforce the documented rule, it just currently does not (because of whats basically an internal technical limitation)
Comment 4 Vít Ondruch 2013-11-14 06:52:41 EST
(In reply to Panu Matilainen from comment #3)
Would you like me to clone this bug or create new one for RPM as well? Or is it already reported somewhere?
Comment 5 Fedora Update System 2014-01-10 09:04:59 EST
scl-utils-20140108-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scl-utils-20140108-1.fc19
Comment 6 Fedora Update System 2014-01-10 09:05:19 EST
scl-utils-20140108-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scl-utils-20140108-1.fc20
Comment 7 Fedora Update System 2014-01-11 03:30:51 EST
Package scl-utils-20140108-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scl-utils-20140108-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0600/scl-utils-20140108-1.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-01-27 07:08:11 EST
scl-utils-20140127-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scl-utils-20140127-1.fc19
Comment 9 Fedora Update System 2014-01-27 07:08:44 EST
scl-utils-20140127-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scl-utils-20140127-1.fc20
Comment 10 Fedora Update System 2014-03-01 09:06:03 EST
scl-utils-20140127-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-03-01 09:13:58 EST
scl-utils-20140127-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.