Bug 1023630 - enable-valgrind-daemon option breaks UML
enable-valgrind-daemon option breaks UML
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 06:00 EDT by Richard W.M. Jones
Modified: 2017-06-27 07:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 07:14:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-10-26 06:00:19 EDT
Description of problem:

User-Mode Linux is broken when ./configure --enable-valgrind-daemon
is used.

Version-Release number of selected component (if applicable):

libguestfs 1.25.1

How reproducible:

100%

Steps to Reproduce:
1. ./configure --enable-valgrind-daemon
2. make
3. make check-uml

Actual results:

The UML process fails with:

guestfsd: main_loop: proc 282 (internal_autosync) took 0.10 seconds
guestfsd: main_loop: new request, len 0x28
Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000000

CPU: 0 PID: 1 Comm: init Not tainted 3.12.0-rc5-00123-g04919af #20
91041c48 91041c80 60052c5e 91041ca0 604c1c90 9103f1c0 00000001 91041c90 
       6036ddb1 91041d90 60368dd1 91041cb0 3000000010 91041da0 91041cc0 00000000 
       00000000 9103f1c0 0000001d 00000000 00000000 9126c4a8 00000000 00000000 
Call Trace: 
91041c58:  [<60052c5e>] dump_stack_print_info+0xa5/0xae
91041c88:  [<6036ddb1>] dump_stack+0x17/0x19
91041c98:  [<60368dd1>] panic+0xf7/0x1e4
91041d38:  [<6004d495>] enqueue_task_fair+0x7f/0x193
91041d98:  [<6002fa06>] forget_original_parent+0xb6/0x366
91041e08:  [<60030ec4>] do_exit+0x24b/0x3ce
91041e48:  [<600310dd>] do_group_exit+0x68/0xc5
91041e78:  [<60031149>] __wake_up_parent+0x0/0x23
91041e88:  [<600186cb>] handle_syscall+0x53/0x64
91041ea8:  [<600278a7>] userspace+0x342/0x400
91041f48:  [<6009564f>] do_execve+0x3df/0x4ef
91041fd8:  [<60015d0f>] new_thread_handler+0x93/0x95


Pid: 1, comm: init Not tainted 3.12.0-rc5-00123-g04919af
RIP: 0033:[<00000038dc2bd719>]
RSP: 0000007fbfd3daf8  EFLAGS: 00000246
RAX: ffffffffffffffda RBX: 0000000000000000 RCX: ffffffffffffffff
RDX: 0000000000000000 RSI: 0000000000000000 RDI: 0000000000000000
RBP: 00000038dc5b6830 R08: 000000000000003c R09: 00000000000000e7
R10: ffffffffffffff80 R11: 0000000000000246 R12: 00000038dc5b6830
R13: 00000038dc5bbea0 R14: 00000000008f2570 R15: 00000000008f3260
Call Trace: 
91041c28:  [<600181b0>] panic_exit+0x2b/0x41
91041c38:  [<60016cf8>] show_stack+0x67/0xa7
91041c48:  [<6004814f>] notifier_call_chain+0x39/0x5c
91041c88:  [<60048212>] atomic_notifier_call_chain+0xf/0x11
91041c98:  [<60368de2>] panic+0x108/0x1e4
91041d38:  [<6004d495>] enqueue_task_fair+0x7f/0x193
91041d98:  [<6002fa06>] forget_original_parent+0xb6/0x366
91041e08:  [<60030ec4>] do_exit+0x24b/0x3ce
91041e48:  [<600310dd>] do_group_exit+0x68/0xc5
91041e78:  [<60031149>] __wake_up_parent+0x0/0x23
91041e88:  [<600186cb>] handle_syscall+0x53/0x64
91041ea8:  [<600278a7>] userspace+0x342/0x400
91041f48:  [<6009564f>] do_execve+0x3df/0x4ef
91041fd8:  [<60015d0f>] new_thread_handler+0x93/0x95

libguestfs: sending SIGTERM to process 13120
libguestfs: error: /home/rjones/d/linux-um/linux killed by signal 6 (Aborted), see debug messages above

Expected results:

No error.

Additional info:

This seems to be because of the new way where the daemon exits
and presumably the init process exits shortly afterwards.

This does not affect production builds since they should not be
using --enable-valgrind-daemon.
Comment 1 Pino Toscano 2017-06-27 07:14:53 EDT
--enable-valgrind-daemon was removed with commit 7bc6fb245183c040bbda222b92fab495cc951052, and commits before that one removed other parts of the valgrind handling in the appliance.

Note You need to log in before you can comment on or make changes to this bug.