Bug 1023666 - python-gunicorn should depend on python-setuptools
python-gunicorn should depend on python-setuptools
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-gunicorn (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Dan Callaghan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 15:09 EDT by Suren Karapetyan
Modified: 2013-11-30 21:53 EST (History)
2 users (show)

See Also:
Fixed In Version: python-gunicorn-18.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-30 21:53:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suren Karapetyan 2013-10-26 15:09:42 EDT
Description of problem:
gunicorn imports pkg_resources so it needs python-setuptools to run.

Version-Release number of selected component (if applicable):
python-gunicorn-0.14.6-1.el6.noarch

Steps to Reproduce:
1. yum remove python-setuptools
2. yum install python-gunicorn
3. gunicorn -h

Actual results:
Traceback (most recent call last):
  File "/usr/bin/gunicorn", line 5, in <module>
    from pkg_resources import load_entry_point

Expected results:
gunicorn help text

btw: will it be possible to update gunicorn to 0.17.2 (it's in fedora repos) or 0.17.4 or even better: 18.0?
Comment 1 Dan Callaghan 2013-11-11 23:14:46 EST
I wasn't updating Gunicorn on older releases because there were a few changes that were "incompatible", but looking back over the changelog I don't think there is anything that would break sane usage of Gunicorn. And it is much better to have 18.0 everywhere instead of a mix of old versions.

So I will update el6, f18 and f19 to Gunicorn 18.0, including adding the missing Requires: python-setuptools.
Comment 2 Fedora Update System 2013-11-11 23:33:25 EST
python-gunicorn-18.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-gunicorn-18.0-1.fc20
Comment 3 Fedora Update System 2013-11-11 23:34:09 EST
python-gunicorn-18.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-gunicorn-18.0-1.el6
Comment 4 Fedora Update System 2013-11-11 23:34:41 EST
python-gunicorn-18.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-gunicorn-18.0-1.fc19
Comment 5 Fedora Update System 2013-11-11 23:35:10 EST
python-gunicorn-18.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-gunicorn-18.0-1.fc18
Comment 6 Fedora Update System 2013-11-13 13:49:55 EST
Package python-gunicorn-18.0-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-gunicorn-18.0-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12088/python-gunicorn-18.0-1.el6
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-23 14:38:10 EST
python-gunicorn-18.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-23 14:39:29 EST
python-gunicorn-18.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-11-23 23:03:36 EST
python-gunicorn-18.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Ernest W. Durbin III 2013-11-28 17:09:16 EST
Is there an ETA for EL6?

Got hit with this issue today.
Comment 11 Dan Callaghan 2013-11-28 17:20:20 EST
As mentioned in comment 6, python-gunicorn-18.0-1.el6 is available from updates-testing.

I thought I hit the button to push it to stable yesterday but evidently not. I've done it just now so it should land in the stable repos in a day or two.
Comment 12 Ernest W. Durbin III 2013-11-28 17:23:04 EST
Thank you!
Comment 13 Fedora Update System 2013-11-30 21:53:21 EST
python-gunicorn-18.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.