Bug 1023670 - perl warning
perl warning
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
: 1054723 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 16:23 EDT by Fabrice Bellet
Modified: 2014-01-17 10:58 EST (History)
7 users (show)

See Also:
Fixed In Version: spamassassin-3.3.2-18.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 01:09:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2013-10-26 16:23:03 EDT
This perl warning is triggered by spamd and occurs quite frequently in my /var/log/maillog file:


Oct 26 22:15:41 lxorgfr spamd[8739]: Use of each() on hash after insertion without resetting hash iterator results in undefined behavior, Perl interpreter: 0x22f7010 at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/AsyncLoop.pm line 363.
Comment 1 Lars E. Pettersson 2013-12-28 15:32:14 EST
There seems to be an upstream fix/patch available for this from May this year: <https://issues.apache.org/SpamAssassin/show_bug.cgi?id=6937>
Comment 2 Fabrice Bellet 2013-12-29 16:21:37 EST
yes, good catch, I confirm that the proposed patch works for me.
Comment 3 Lars E. Pettersson 2013-12-30 07:07:21 EST
I have now tested the patch I mentioned before and it seems to work for me also. No ill effects noted yet at least.
Comment 4 Kevin Fenzi 2014-01-04 14:22:03 EST
Can you test this scratch build: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=6360100

I had to monkey with the patch to get it to apply, so confirmation that it's working would be great.
Comment 5 Lars E. Pettersson 2014-01-05 07:12:44 EST
Kevin, the build from koji seem to work, no problem detected here.
Comment 6 Fedora Update System 2014-01-05 10:16:34 EST
spamassassin-3.3.2-18.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/spamassassin-3.3.2-18.fc20
Comment 7 Fedora Update System 2014-01-07 04:38:49 EST
Package spamassassin-3.3.2-18.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spamassassin-3.3.2-18.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0290/spamassassin-3.3.2-18.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-01-15 01:09:55 EST
spamassassin-3.3.2-18.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Kevin Fenzi 2014-01-17 10:58:38 EST
*** Bug 1054723 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.