Bug 1023686 - roundcube mail httpd conf denies access to all except localhost
roundcube mail httpd conf denies access to all except localhost
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: roundcubemail (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-26 23:13 EDT by Mohammed Arafa
Modified: 2013-11-06 14:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 14:44:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2013-10-26 23:13:01 EDT
Description of problem:
in /etc/httpd/conf.d/roundcubemail.conf there is a stanza that denies access to all except localhost.
that kind of defeats the purpose of having web mail. on localhost we can read mail with mail or mutt or alpine or read the actual mail file in /var/mail etc etc etc. 
web mail on the other hand is meant for the web, the cloud so to speak but limiting it to only localhost defeats its purpose.

pls. remove this stanza

thank you

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Gwyn Ciesla 2013-11-06 14:44:37 EST
This is by design, so that simply installing the software doesn't expose it to the public network.  This is a common web application packaging practice.  Commenting out this stanza can be done at any time by the administrator, once other configuration is complete.

Note You need to log in before you can comment on or make changes to this bug.