Bug 1023720 - Dell Wireless 365 bluetooth not detected
Dell Wireless 365 bluetooth not detected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 06:29 EDT by Rémi G.
Modified: 2016-07-01 13:44 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-17 11:36:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rémi G. 2013-10-27 06:29:13 EDT
Bluetooth is not working on my Dell Vostro 3300 laptop with a Dell Wireless 365 bluetooth. In the bluetooth entry of the GNOME settings, I can read: "No Bluetooth adapters found".

Indeed, I can't even see my bluetooth adapter using lsusb:

$ lsusb | grep Bluetooth
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)

Whereas, It's working properly in Ubuntu GNOME 3.10 and in previous versions for example :

$ lsusb | grep Bluetooth
Bus 001 Device 008: ID 413c:8160 Dell Computer Corp. Wireless 365 Bluetooth
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)

And yet, my bluetooth adapter seems to be powered (I check the BIOS and the indicator light is turned on).

I'm using Fedora 20 with the latest kernel 3.11.6-301.fc20.x86_64 and every thing seems up-to-date.
Comment 1 abaahy 2013-11-16 09:18:39 EST
I have the same problem using Fedora 20 (3.11.8-300.fc20.x86_64) on my Dell Studio 1555.

$ lsusb | grep Bluetooth
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Comment 2 Michele Baldessari 2013-11-16 12:14:36 EST
Hi Remi,

which is the exact kernel version on Ubuntu where you are able to see the device?
Probably a regression in later kernel, I'd say.

regards,
Michele
Comment 3 Rémi G. 2013-11-17 07:13:54 EST
Hi Michele,

I have tried a few live disks:

* Fedora 19-1 : ok (after installing bluez-hid2hci)
  - kernel: 3.9.5-301.fc19.x86_64
  - bluez: 4.101

* Ubuntu 13.10 : ok
  - kernel: 3.11.0-12-generic
  - bluez: 4.101-0ubuntu8b1
  
* Ubuntu 14.04 (nightly build from 2013-11-10) : ok 
  - kernel: 3.12.0-2-generic
  - bluez: 4.101-0ubuntu8b1

* Fedora 20 beta : not working
  - kernel: 3.11.8-300
  - bluez: 5.10-3
  
Don't hesitate if you need more information.
Comment 4 Michele Baldessari 2013-11-17 08:49:38 EST
Hi Remi,

thanks this helps. From the comment above, I'd say that this is a fallout
from the bluez 4->5 migration more than a kernel issue. 

I assume you have bluez-hid2hci installed on F20 beta as well yes?

Also, do you see any crashes of bluetoothd in the message logs? I ask because
I see quite a few reported already against bluez-5:
https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=POST&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=RELEASE_PENDING&classification=Fedora&component=bluez&component=bluez-libs&component=bluez-pan&component=bluez-pin&component=bluez-sdp&component=bluez-utils&list_id=1908839&product=Fedora&query_format=advanced

hth,
Michele
Comment 5 Rémi G. 2013-11-17 10:09:30 EST
I have bluez-hid2hci installed and I don't see any crashes in the application "Automatic Bug Reporting Tool".

The bluetooth service is "active (running)" according to the following command:

    sudo systemctl status bluetooth

Since I don't know what you meant by message logs, I also tried the following command (I don't know systemd, so maybe that's not what you asked):

    sudo journalctl _SYSTEMD_UNIT=bluetooth.service

Here is typically what I get:

    -- Reboot --
    nov. 17 12:56:49 vostro3300 bluetoothd[1118]: Bluetooth daemon 5.10
    nov. 17 12:56:49 vostro3300 bluetoothd[1118]: Starting SDP server
    nov. 17 12:56:49 vostro3300 bluetoothd[1118]: Bluetooth management interface 1.3 initialized
    -- Reboot --
Comment 6 Rémi G. 2013-12-17 03:12:31 EST
The problem is solved for me after a recent update (maybe from yesterday). Here are the versions installed for my packages:

bluez-5.12-1
kernel-3.11.10-301

Right in time for Fedora 20 release! Should I close the bug or do you need additional information before?
Comment 7 Josh Boyer 2013-12-17 11:36:04 EST
Thanks for letting us know.  Closing this out.
Comment 8 Pablo Castorino 2016-06-29 08:45:25 EDT
After upgrade system (23 -> 24), the device can't be detected anymore. lsusb show the device but btusb is not loaded at boot. 

lsusb:
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth

i try loading module manually but still without appears.

hcitool devices:
Devices:


F23 (OK): 
kernel-core-4.5.7-200.fc23.x86_64
bluez-5.39-1.fc23.x86_64
bluez-cups-5.39-1.fc23.x86_64
bluez-hid2hci-5.39-1.fc23.x86_64
bluez-libs-5.39-1.fc23.x86_64

F24 (NOT WORK):
kernel-core-4.5.7-300.fc24.x86_64
bluez-5.40-1.fc23.x86_64
bluez-cups-5.40-1.fc23.x86_64
bluez-hid2hci-5.40-1.fc23.x86_64
bluez-libs-5.40-1.fc23.x86_64
Comment 9 Pablo Castorino 2016-07-01 13:44:15 EDT
I updated F24 kernel (2.6.3-300) but still without detect bluetooth. 

F23 $ lsusb
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0c45:6417 Microdia Integrated Webcam
Bus 001 Device 007: ID 413c:8160 Dell Computer Corp. Wireless 365 Bluetooth
Bus 001 Device 006: ID 413c:8162 Dell Computer Corp. Integrated Touchpad [Synaptics]
Bus 001 Device 005: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

F24 $ lsusb
Bus 002 Device 002: ID 8087:0020 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 
Bus 001 Device 004: ID 0c45:6417 Microdia Integrated Webcam
Bus 001 Device 006: ID 413c:8162 Dell Computer Corp. Integrated Touchpad [Synaptics]
Bus 001 Device 005: ID 413c:8161 Dell Computer Corp. Integrated Keyboard
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 002: ID 8087:0020 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation

Note You need to log in before you can comment on or make changes to this bug.