Bug 1023722 - [oVirt-webadmin][network] Network roles in cluster management should be radio buttons
[oVirt-webadmin][network] Network roles in cluster management should be radio...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
medium Severity low
: ---
: 3.5.0
Assigned To: Lior Vernia
Michael Burman
network
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 06:58 EDT by Mike Kolesnik
Modified: 2016-02-10 14:36 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-17 08:24:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current manage networks under cluster (18.64 KB, image/png)
2013-10-27 06:58 EDT, Mike Kolesnik
no flags Details
Shouldn't change - manage network attachment to multiple clusters (15.89 KB, image/png)
2013-10-27 06:59 EDT, Mike Kolesnik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22060 None None None Never
oVirt gerrit 22382 master MERGED core: Mark management network as display and migration Never

  None (edit)
Description Mike Kolesnik 2013-10-27 06:58:35 EDT
Created attachment 816493 [details]
Current manage networks under cluster

Description of problem:
When openinng "Manage Networks" dialog in a cluster, the network roles (display, migration) appear as check boxes, while they should appear as radio buttons. (See attached screenshot for clarification)
The rationale is simple - you can have only one network performing each role at the cluster level, and checkboxes make you think that it's possible to have more than one.
Additionally, in the current behaviour it's not reflected that the management network performs these roles when no other network is selected to do so, while it would be clearer if radio buttons were used.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Add a couple of networks to the DC
2. Add a cluster
3. Go to networks sub-tab in the cluster, and click "Manage Networks"

Actual results:
The dialog is presenting checkboxes for the network roles


Expected results:
The dialog should present radio buttons and have the management network selected by default for these roles.


Additional info:
Please note that the checkboxes ARE CORRECT for the "Manage Network" dialog that you get when you go to a specific network's clusters sub-tab.
Comment 1 Mike Kolesnik 2013-10-27 06:59:31 EDT
Created attachment 816494 [details]
Shouldn't change - manage network attachment to multiple clusters
Comment 2 Sandro Bonazzola 2013-11-28 10:34:10 EST
Re-targeting to 3.3.3 since the bug is not resolved in 3.3.2 beta and is not blocking 3.3.2 release tracker (bug #1027349)
Comment 3 Sandro Bonazzola 2014-01-13 08:56:42 EST
oVirt 3.4.0 alpha has been released including the fix for this issue.
Comment 4 Moti Asayag 2014-02-17 02:42:35 EST
Moving to POST, the fix should include also [1] to set the default network for the roles.

[1] http://gerrit.ovirt.org/#/c/22382/
Comment 5 Meni Yakove 2014-07-28 01:01:50 EDT
ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
Comment 6 Sandro Bonazzola 2014-10-17 08:24:57 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.