Bug 1023727 - yum update from command line tries to install a zillion language packages
yum update from command line tries to install a zillion language packages
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 08:41 EDT by Simon Lewis
Modified: 2014-01-27 15:49 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-27 15:49:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
konsole output when running (437.71 KB, text/plain)
2013-10-27 08:41 EDT, Simon Lewis
no flags Details

  None (edit)
Description Simon Lewis 2013-10-27 08:41:32 EDT
Created attachment 816515 [details]
konsole output when running

This is driving me crazy...

When running 

su -c "yum update" 

from the command line, yum wants to install a zillion language packages - see attachment for konsole output.

If I start yumex, yumex indicates there are no packages to update.

Please advise how to solve the problem.

I have already tried:

yum clean all

and

rm -f /var/lib/rpm/__db*
rpm -vv –rebuilddb
rpm -qa
Comment 1 Jan Zeleny 2013-10-30 05:35:37 EDT
So I assume the problem is just with those language packages, right? Are you sure you don't have all these packages installed already? Try rpm -qa | grep hunspell for example, the same for all the package you don't think should be updated. If those packages are installed and have updates, it's logical that yum wants to update them.
Comment 2 Simon Lewis 2013-10-30 12:14:35 EDT
Hi Jan

Thanks for your quick reply, definitely something buggy - take hunspell for example:

# rpm -qa | grep hunspell
hunspell-de-0.20120607-3.fc19.noarch
hunspell-en-US-0.20121024-5.fc19.noarch
hunspell-1.3.2-13.fc19.x86_64
#

but "yum update" wants to install:

---> Paket hunspell-am.noarch 0:0.20090704-6.fc19 markiert, um installiert zu werden
---> Paket hunspell-ar.noarch 0:0.20080110-9.fc19 markiert, um installiert zu werden
---> Paket hunspell-as.noarch 0:1.0.3-8.fc19 markiert, um installiert zu werden
---> Paket hunspell-bn.noarch 1:0.06-3.fc19 markiert, um installiert zu werden
---> Paket hunspell-gu.noarch 0:20061015-10.fc19 markiert, um installiert zu werden
---> Paket hunspell-he.x86_64 0:1.2-4.fc19 markiert, um installiert zu werden
---> Paket hunspell-hi.noarch 0:20050726-11.fc19 markiert, um installiert zu werden
---> Paket hunspell-km.noarch 0:1.1-6.fc19 markiert, um installiert zu werden
---> Paket hunspell-kn.noarch 0:1.0.3-6.fc19 markiert, um installiert zu werden
---> Paket hunspell-ko.noarch 0:0.5.5-4.fc19 markiert, um installiert zu werden
---> Paket hunspell-mai.noarch 0:1.0.1-6.fc19 markiert, um installiert zu werden
---> Paket hunspell-ml.noarch 0:0.1-9.fc19 markiert, um installiert zu werden
---> Paket hunspell-or.noarch 1:0.03-2.fc19 markiert, um installiert zu werden
---> Paket hunspell-pa.noarch 0:20050726-9.fc19 markiert, um installiert zu werden
---> Paket hunspell-ta.noarch 0:20100226-7.fc19 markiert, um installiert zu werden
---> Paket hunspell-te.noarch 0:0.20050929-10.fc19 markiert, um installiert zu werden
---> Paket hunspell-th.noarch 0:0.20061212-9.fc19 markiert, um installiert zu werden
---> Paket hunspell-yi.noarch 0:1.1-6.fc19 markiert, um installiert zu werden

The same applies to libreoffice-langpack

# rpm -qa | grep libreoffice-langpack
libreoffice-langpack-de-4.1.2.3-3.fc19.x86_64
#

but "yum update" wants to install:

---> Paket libreoffice-langpack-ar.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-as.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-bn.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-gu.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-he.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-hi.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-ja.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-kn.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-ko.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-mai.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-ml.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-or.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-pa.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-ta.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-te.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-th.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden
---> Paket libreoffice-langpack-zh-Hant.x86_64 1:4.1.2.3-3.fc19 markiert, um installiert zu werden

Strangely yumex is not showing this behaviour - only yum when run from the command line.

With best regards, Simon
Comment 3 Jan Zeleny 2013-10-31 03:34:30 EDT
Looks like another problem in yum-langpacks plugin, reassigning for further evaluation.
Comment 4 Parag Nemade 2013-10-31 04:05:03 EDT
show me output of commands
1) locale
2) cat /var/lib/yum/plugins/langpacks/installed_langpacks

I am not sure if yumex considers yum-langpacks plugin.
Comment 5 Parag Nemade 2013-11-01 03:08:04 EDT
I can't reproduce this on my fedora 19 system.
Comment 6 Simon Lewis 2013-11-01 04:20:09 EDT
Hello Jan

Here is the info you requested

$locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
$

I don't have a directory /var/lib/yum/plugins/langpacks/installed_langpacks

But I did find the following, which is strange as the only groups I have deliberately installed are "KDE Plasma-Arbeitsumgebung" and "RPM Development Tools", I guess my yum configuration is totally shot:

# cat /var/lib/yum/groups/*
1
0
1
73
admin-tools
0
arabic-support
0
assamese-support
0
authoring-and-publishing
0
bengali-support
0
bhutanese-support
0
bodo-support                                                                                                                                                 
0                                                                                                                                                            
buildsys-build                                                                                                                                               
0                                                                                                                                                            
burmese-support                                                                                                                                              
0                                                                                                                                                            
core
0
critical-path-apps
0
critical-path-kde
0
design-suite
0
development-tools
0
dial-up
0
dogri-support
0
education
0
electronic-lab
0
ethiopic-support
0
fonts
0
games
0
georgian-support
0
graphical-internet
0
graphics
0
guest-agents
0
guest-desktop-agents
0
gujarati-support
0
hardware-support
0
hebrew-support
0
hindi-support
0
input-methods
0
japanese-support
0
java
0
kannada-support
0
kashmiri-support
0
kde-media
0
kde-software-development
0
khmer-support
0
konkani-support
0
korean-support
0
legacy-fonts
0
lepcha-support
0
libreoffice
0
mail-server
0
maithili-support
0
malayalam-support
0
manipuri-support
0
milkymist
0
multimedia
0
mysql
0
network-server
0
office
0
oriya-support
0
punjabi-support
0
robotics-suite
0
rpm-development-tools
0
russian-support
0
sanskrit-support
0
santali-support
0
security-lab
0
server-cfg
0
simplified-chinese-support
0
sinhala-support
0
sound-and-video
0
system-tools
0
tamil-support
0
telugu-support
0
text-internet
0
thai-support
0
traditional-chinese-support
0
web-server
0
window-managers
0
yiddish-support
0
#


Can I just delete /var/lib/yum/ and start again?

With best regards, Simon
Comment 7 Jan Zeleny 2013-11-01 04:31:07 EDT
Setting needinfo: James, is it possible the issue is somewhere in the "groups as objects" behavior?
Comment 8 James Le Cuirot 2013-11-18 06:07:35 EST
I saw this after running "yum groups mark convert". Why did I run that? yum told me to when I tried to do anything group-related. Admittedly I didn't understand what it meant but this F19 system started out as F16 so I figured it was some legacy thing that needed to be converted.

I ended up having to blitz a huge list of groups with "yum group mark remove". There were so many language groups, I ended up removing those with the help of xargs. :|
Comment 9 Simon Lewis 2013-11-19 14:15:09 EST
Hello James

That is it. At some stage Yum advised to run "yum groups mark convert" after updating my FC19 system.

Please advise a script or "HOW TO" using xargs to remove all language groups except British-English and German-German.

Best regards, Simon
Comment 10 James Le Cuirot 2013-11-20 05:30:57 EST
Hello Simon. It wasn't particularly scientific. It also took out a couple of other groups with "Support" in the name but I went ahead because I generally find these groups less than helpful in any case. I use XFCE but the "Xfce Desktop" environment group insists on installing a bunch of things that I really don't need.

yum group info \* | fgrep " Support" | grep "Group:" | cut -d" " -f2- | xargs -I{} yum group mark remove "{}"
Comment 11 James Le Cuirot 2013-11-20 05:32:46 EST
By the way, there are no groups for English or German so you don't need to worry about those.
Comment 12 Parag Nemade 2013-11-20 23:33:17 EST
moving this to yum component as some of above comments are related to yum package actually.
Comment 13 Simon Lewis 2013-11-22 12:42:34 EST
(In reply to James Le Cuirot from comment #10)

I admit I am not quite fit on the command line, the 2 "yum group" commands didn't do anything obvious.

How should I remove the following groups?

"Arabic Support" "Assamese Support" "Bengali Support" "Bhutanese Support" "Bodo Support" "Dogri Support" "Georgian Support" "Gujarati Support" "Hebrew Support" "Hindi Support" "Japanese Support" "Kannada Support" "Kashmiri Support" "Khmer Support" "Konkani Support" "Korean Support" "Lepcha Support" "Maithili Support" "Malayalam Support" "Manipuri Support" "Marathi Support" "Myanmar (Burmese) Support" "Nepali Support" "Oriya Support" "Punjabi Support" "Russian Support" "Sanskrit Support" "Santali Support" "Sindhi Support" "Sinhala Support" "Tamil Support" "Telugu Support" "Thai Support" "Tibetan Support" "Traditional Chinese Support" "Urdu Support" "Yiddish Support"

"yum groupremove"  says that these environmental groups don't exist

"yum list-groups" says these packages / groups are installed..

Any help would be really welcome.
Comment 14 Parag Nemade 2013-11-23 11:00:06 EST
If I have some group installed and I want yum to consider it as if its not installed then I use command
yum group mark remove <groupname>

This does not remove the installed packages from that group but just mark it removed.
Comment 15 James Le Cuirot 2013-11-24 10:00:31 EST
Parag is right. This will not appear to do much at first but it should cause yum update to install much fewer packages.
Comment 16 Jan Zeleny 2013-11-25 02:59:25 EST
(In reply to Simon Lewis from comment #13)
> (In reply to James Le Cuirot from comment #10)
> 
> I admit I am not quite fit on the command line, the 2 "yum group" commands
> didn't do anything obvious.
> 
> How should I remove the following groups?
> 
> "Arabic Support" "Assamese Support" "Bengali Support" "Bhutanese Support"
> "Bodo Support" "Dogri Support" "Georgian Support" "Gujarati Support" "Hebrew
> Support" "Hindi Support" "Japanese Support" "Kannada Support" "Kashmiri
> Support" "Khmer Support" "Konkani Support" "Korean Support" "Lepcha Support"
> "Maithili Support" "Malayalam Support" "Manipuri Support" "Marathi Support"
> "Myanmar (Burmese) Support" "Nepali Support" "Oriya Support" "Punjabi
> Support" "Russian Support" "Sanskrit Support" "Santali Support" "Sindhi
> Support" "Sinhala Support" "Tamil Support" "Telugu Support" "Thai Support"
> "Tibetan Support" "Traditional Chinese Support" "Urdu Support" "Yiddish
> Support"
> 
> "yum groupremove"  says that these environmental groups don't exist

That's because they really don't. These are not groups, they are language packs. See yum-langpacks(8) for more information.
Comment 17 Parag Nemade 2013-11-25 03:11:08 EST
They are not language packs at least not related to yum-langpacks plugin at all. I am not sure when we removed language groups support from comps whether we took care of yum group issues like this one if arises in future.

No langpacks command ever needed to input/output arguments like "Hindi support" or "Marathi support" or any of above listed groups. Since its development it still accepts input as just locale code like ar or as or mr
Comment 18 Jan Zeleny 2013-11-25 03:21:09 EST
(In reply to Parag from comment #17)
> They are not language packs at least not related to yum-langpacks plugin at
> all. I am not sure when we removed language groups support from comps
> whether we took care of yum group issues like this one if arises in future.

Hm, we probably have a culprit. I am not sure about the transition myself, perhaps James will have more information on this.
Comment 19 Simon Lewis 2013-12-11 09:45:01 EST
This was still bugging me - so I deleted the following directories and the problem has gone away:

/var/cache/yum

/var/tmp/yum-*

/var/lib/yum
Comment 20 James Antill 2014-01-27 15:49:31 EST
> I saw this after running "yum groups mark convert". Why did I run that?

This is likely now fixed with the last set of group fixes where we blacklist stuff on "mark convert" instead of whitelisting it.

Note You need to log in before you can comment on or make changes to this bug.