Bug 1023766 - Eclipse / SVN / gnome-keyring bug
Eclipse / SVN / gnome-keyring bug
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 14:37 EDT by Steevithak
Modified: 2013-10-28 11:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 03:31:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steevithak 2013-10-27 14:37:01 EDT
Description of problem: When installing eclipse from the Fedora repository, the user is presented with a cryptic error message complaining about an incompatibility between subversion, gnome-keyring, and subeclipse, with the result that eclipse asks the user to apparently disable gnome-keyring, which sounds a bit dangerous if it is already being used by other apps.


Version-Release number of selected component (if applicable):
Fedora 19
eclipse-platform.x86-64 1:4.3.1-5.fc19
subversion.x86_64 0:1.7.13-1.fc19
gnome-keyring-3.8.2-1.fc19.x86_64


How reproducible:
Unknown, only tried installing once


Steps to Reproduce:
1. Install F19
2. Install eclipse as per official instructions found on Fedora site:
http://fedoraproject.org/wiki/HOWTO_Setup_Android_Development
3.

Actual results:
Weird bug that leaves user not knowing what to do. Answering "cancel" will apparently prevent eclipse from working but answering "OK" will apparently disable gnome-keyring (presumably breaking other stuff). The dialog is badly worded though, so it's not really entirely clear what it means or what will happen if either button is clicked. (it says some files will get renamed and moved around but it offers no help as to what effect that will have on your system other than maybe making eclipse run)

Expected results:
The versions of svn, eclipse, and gnome-keyring provided should actually work together

Additional info:

I was attempting to follow the official instructions provided on the Fedora website for installing the Android development environment. These instruction do not address this dialog, suggesting either it's a new problem or that there's a gap in the instructions.

http://fedoraproject.org/wiki/HOWTO_Setup_Android_Development

It may be that this could be fixed by simply improving the dialog so it explains the problem and solution better. It seems to assume the person installing the software is already an expert on eclipse, svn, and gnome-keyring to the extent of knowing what the config files do, where they're stored and what side effects messing with them will have. A first time user is unlikely to know any of that.
Comment 1 Krzysztof Daniel 2013-10-28 03:31:10 EDT
Subclipse documentation [1] says:
> "There is currently a bug in the new support for GNOME keyring in Subversion 1.6. It works OK when using the command line, but not when other users of the libraries use it. Until this is fixed, you can workaround the problem by turning off this feature. "

I found also bug reported against gnome [2]:
> "Subversion chooses to prompt for the gnome-keyring keyring password rather than allow a prompt to be shown for the same. So, this is not a gnome-keyring bug, but a subversion one."

But the most important bit is:
> " by default the keyring password is the same as your (unix) user login
passwd."
so this is the password you're being asked for!

So here we go back to the subversion, and I found there [3], which seems to be the right place to complain about the issue, so I'm closing this as an upstream issue (I pass it to the subclipse community). 

Steve,
thank you for your bug report! I've routed it to a proper place [3]. You may want to follow it there. We need such bug reports to make Linux better! Thanks!

[1] http://subclipse.tigris.org/wiki/JavaHL
[2] https://bugzilla.gnome.org/show_bug.cgi?id=600758
[3] http://subversion.tigris.org/issues/show_bug.cgi?id=3498
Comment 2 Steevithak 2013-10-28 11:54:10 EDT
Thanks, I appreciate the research, I'll follow the upstream bug reports.

Note You need to log in before you can comment on or make changes to this bug.