Bug 1023780 - litd ISO to USB stick successfully creates, but fails to boot, black screen hang no GRUB menu
litd ISO to USB stick successfully creates, but fails to boot, black screen h...
Status: CLOSED DUPLICATE of bug 1023767
Product: Fedora
Classification: Fedora
Component: shim (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Garrett
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 15:59 EDT by Chris Murphy
Modified: 2013-10-28 20:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 16:54:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2013-10-27 15:59:07 EDT
Description of problem: Successful creation of a USB stick of DVD beta TC6 using litd; however it fails to boot an EFI Mac.


Version-Release number of selected component (if applicable):
livecd-tools-20.0-1.fc20
grub2-2.00-25.fc20

How reproducible:
Always with beta TC6 DVD ISO to a specific partition. dd is working.


Steps to Reproduce:
0. Started out with a partitioned 16GB stick, 8GB portion is formatted FAT32.
1. livecd-iso-to-disk --noverify --efi ISO /dev/sdb1
successfully created
2. Reboot using stick.

Actual results:
Black screen flashing underscore cursor, no GRUB menu or error messages.

Expected results:
GRUB menu, then boot.

Additional info:
This was last working with beta TC4. Uncertain when the regression occurred. Since livecd-tools, shim, and grub2 packages haven't changed, the regression isn't there. But I'm going to set to livecd-tools for now.
Comment 1 Chris Murphy 2013-10-27 16:50:33 EDT
Correction: cursor is not flashing

Still fails with these changes:
- New USB stick media, not partitioned, zeroed
- Fedora-Live-Desktop-x86_64-20-Beta-TC6.iso
- Command:
livecd-iso-to-disk --noverify --format --reset-mbr --efi ISO /dev/sdb
Comment 2 Chris Murphy 2013-10-27 18:42:26 EDT
This produces a working USB stick.
livecd-iso-to-disk --noverify --efi --overlay-size-mb 100 Fedora-Live-Desktop-x86_64-20-Beta-TC5.iso /dev/sdb1

Substituting TC6, boot failure as described. So this is a TC6 regression, I think.

The grubx64.efi on the ISOs have identical sha256sums. The bootx64.efi's do not.


[root@f20s BOOT]# sha256sum /mnt/tc5/EFI/BOOT/BOOTX64.efi
f7b7e82ebdeb1818b4bed27c33adb575826acd7ede084086b9cb4e4ee2dda554


[root@f20s BOOT]# sha256sum /mnt/tc6/EFI/BOOT/BOOTX64.efi 
7c3f863cbff4db18689d6f0dde31e0f1c320763a30c802490709e166c859d39b

I think bootx64.efi is shim.efi, but I don't see a package change so I'm not sure why they have different sha256sums.
Comment 3 Chris Murphy 2013-10-28 00:05:32 EDT
I'm wrong. shim and shim-signed did change between beta TC5 and beta TC6. Nevertheless, Desktop and DVD TC6 ISO boot on EFI Macs when dd'd, yet fail when the stick is created with litd. Weird.
Comment 4 Brian Lane 2013-10-28 13:39:19 EDT
Coping the one from TC5 results in a working USB, so yes, something in shim doesn't seem happy with Apple's EFI.
Comment 5 Chris Murphy 2013-10-28 16:54:00 EDT

*** This bug has been marked as a duplicate of bug 1023767 ***

Note You need to log in before you can comment on or make changes to this bug.