Bug 1023806 - InlineHistory "marked as a duplicate" detection too eager
InlineHistory "marked as a duplicate" detection too eager
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: Performance
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-27 18:45 EDT by Simon Green
Modified: 2014-10-12 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.4.1011
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 20:55:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 928387 None None None Never

  None (edit)
Description Simon Green 2013-10-27 18:45:22 EDT
(from the bmo bug)

Upstreaming from https://bugzilla.wikimedia.org/show_bug.cgi?id=55373
We're using bmo4.2's InlineHistory in bugzilla.wikimedia.org (with small CSS adjustments).

Below https://bugzilla.wikimedia.org/show_bug.cgi?id=45051 comment 6, InlineHistory claims that MZMcBride marked bug 43689 as a duplicate of 45051. This is not true; Krinkle did that in comment 5, and MZMcBride only quoted the automatic comment.
History of 43689 also shows that the duplication was not reverted and applied again (to rule out one potential reason).

The only explanation I see is that InlineHistory "marked as a duplicate"
detection is too eager. It should only trigger when that comment is at the end
of the comment, in a separate paragraph.

Could only find b ug 759768 which seems to be slightly related.
Comment 4 Simon Green 2013-11-21 20:55:27 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.