Bug 1023857 - Failed to add alias for existing app after migration on INT
Failed to add alias for existing app after migration on INT
Status: CLOSED DUPLICATE of bug 1023854
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 02:20 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 17:25:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-10-28 02:20:07 EDT
Description of problem:
It's failed to add alias for existing app after migration.

Version-Release number of selected component (if applicable):
INT(devenv_3948)

How reproducible:
always

Steps to Reproduce:
1.Create an app on INT
rhc app create crb19 ruby-1.9 --no-git
2.Upgrade and migrate INT servers
3.Add alias for this app
rhc alias add crb19 c.c1.com

Actual results:
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node)..
Reference ID: 60aeb3a420ce9351284032cc3eecf986

Expected results:
Add alias for app should be successfully

Additional info:
Comment 1 chunchen 2013-10-28 03:22:59 EDT
This issue is not reproduced on devenv_stage_528 which is upgraded and migrated to devenv_3953.
Comment 2 Rob Millner 2013-10-28 14:11:53 EDT
Can't reproduce:
$ rhc alias add rm1 foo.fiendly.org
Alias 'foo.fiendly.org' has been added.

$ rhc domain show
Domain rmillnerint (owned by rmillner@redhat.com)
-------------------------------------------------
  Created:            10:49 AM
  Allowed Gear Sizes: small

  rm1 @ http://rm1-rmillnerint.int.rhcloud.com/ (uuid: 526ea3d503ef64df6b00013a)
  ------------------------------------------------------------------------------
    Domain:     rmillnerint
    Created:    10:50 AM
    Gears:      1 (defaults to small)
    Git URL:    ssh://526ea3d503ef64df6b00013a@rm1-rmillnerint.int.rhcloud.com/~/git/rm1.git/
    SSH:        526ea3d503ef64df6b00013a@rm1-rmillnerint.int.rhcloud.com
    Deployment: auto (on git push)
    Aliases:    foo.fiendly.org

    php-5.3 (PHP 5.3)
    -----------------
      Gears: 1 small

You have 1 application in your domain.
Comment 3 Rob Millner 2013-10-28 17:25:15 EDT

*** This bug has been marked as a duplicate of bug 1023854 ***

Note You need to log in before you can comment on or make changes to this bug.