This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1023881 - System list does not show the 'OS' name of registered system
System list does not show the 'OS' name of registered system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Walden Raines
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: Triaged
: 1096168 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 04:18 EDT by Sachin Ghai
Modified: 2016-04-22 11:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 08:27:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OS name is missing under system list (40.93 KB, image/png)
2013-10-28 04:18 EDT, Sachin Ghai
no flags Details
OS is now shown in UI (53.85 KB, image/png)
2014-07-24 17:36 EDT, sthirugn@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6260 None None None 2016-04-22 11:40 EDT

  None (edit)
Description Sachin Ghai 2013-10-28 04:18:37 EDT
Created attachment 816714 [details]
OS name is missing under system list

Description of problem:
'OS' column doesn't display the OS name under system list. 


Version-Release number of selected component (if applicable):
Snap7 compose2 (MPD2)

signo-katello-0.0.23-2.el6sat.noarch
katello-1.4.6-49.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-common-1.4.3-27.el6sat.noarch
katello-foreman-all-1.4.6-49.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.6-49.el6sat.noarch
katello-glue-pulp-1.4.6-49.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-7.el6sat.noarch
katello-configure-1.4.7-7.el6sat.noarch
katello-glue-candlepin-1.4.6-49.el6sat.noarch
katello-cli-1.4.3-27.el6sat.noarch
katello-all-1.4.6-49.el6sat.noarch
katello-common-1.4.6-49.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Register a system
2. Go to -Systems --> All
3.

Actual results:
Missing OS name under "OS' column

Expected results:
'OS' column should show the OS of registered system.

Additional info:
Comment 3 Walden Raines 2014-06-17 16:32:02 EDT
Created redmine issue http://projects.theforeman.org/issues/6260 from this bug
Comment 4 Walden Raines 2014-06-17 16:35:44 EDT
PR: https://github.com/Katello/katello/pull/4292
Comment 5 Walden Raines 2014-06-17 17:03:13 EDT
commit e958c05f49cf64b887aead8c9dbfb6c9f2dde6a8
Merge: c5bbf04 13f99a7
Author: Walden Raines <walden@redhat.com>
Date:   Tue Jun 17 17:02:16 2014 -0400

    Merge pull request #4292 from waldenraines/6260
    
    Fixes #6260/BZ1023881 - display OS on content host index page.

commit 13f99a7d5e31d30be05ce5d7183a5d73a52e9317
Author: Walden Raines <walden@redhat.com>
Date:   Tue Jun 17 16:32:13 2014 -0400

    Fixes #6260/BZ1023881 - display OS on content host index page.
Comment 6 Brad Buckingham 2014-06-28 12:32:11 EDT
*** Bug 1096168 has been marked as a duplicate of this bug. ***
Comment 8 sthirugn@redhat.com 2014-07-24 17:36:01 EDT
Verified. (see screenshot)

Version Tested: Satellite-6.0.4-RHEL-6-20140723.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.32-1.el6sat.noarch
* foreman-compute-1.6.0.32-1.el6sat.noarch
* foreman-gce-1.6.0.32-1.el6sat.noarch
* foreman-libvirt-1.6.0.32-1.el6sat.noarch
* foreman-ovirt-1.6.0.32-1.el6sat.noarch
* foreman-postgresql-1.6.0.32-1.el6sat.noarch
* foreman-proxy-1.6.0.22-1.el6sat.noarch
* foreman-selinux-1.6.0.3-1.el6sat.noarch
* foreman-vmware-1.6.0.32-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64
Comment 9 sthirugn@redhat.com 2014-07-24 17:36:21 EDT
Created attachment 920748 [details]
OS is now shown in UI
Comment 11 Bryan Kearney 2014-09-11 08:27:25 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.