Bug 1023902 - Always show "hot_deploy marker found" during deployment if rhc deploy nodejs app with hot-deploy option once
Always show "hot_deploy marker found" during deployment if rhc deploy nodejs ...
Status: CLOSED DUPLICATE of bug 1022271
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 05:47 EDT by Yan Du
Modified: 2015-05-14 19:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 09:20:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-10-28 05:47:38 EDT
Description of problem:

manally deploy nodejs app with hot-deploy option, then make some change and deploy the app again without hot-deploy option, still show  "hot_deploy marker found." during deployment.



Version-Release number of selected component (if applicable):
INT(devenv_3948)



How reproducible:
Always



Steps to Reproduce:

1. create nodejs-0.10 app and disable auto_deploy
2. make some change in repo and deploy the app with hot-deploy option
   #rhc deploy $commitID -a $app --hot-deploy
3. make some change again and deploy without hot-deploy option
   #rhc deploy $commitID -a $app



Actual results:

Always show "hot_deploy marker found." even deploy the app without hot-deploy option, but app can stop/start normally during deployment.

step3:
[root@localhost n10]# rhc deploy f5b27d3 -a n10 

Deployment of git ref 'f5b27d3' in progress for application n10 ...
Stopping NodeJS cartridge
hot_deploy marker found. Switching to using supervisor. Subsequent pushes won't require restart until the marker is removed.  
Saving away previously installed Node modules
Building git ref 'f5b27d3', commit f5b27d3
Building NodeJS cartridge
npm info it worked if it ends with ok
npm info using npm@1.2.17
npm info using node@v0.10.5
npm info preinstall OpenShift-Sample-App@1.0.0
npm info build /var/lib/openshift/526e2b416cec0e1ddf0000d4/app-root/runtime/repo
npm info linkStuff OpenShift-Sample-App@1.0.0
npm info install OpenShift-Sample-App@1.0.0
npm info postinstall OpenShift-Sample-App@1.0.0
npm info prepublish OpenShift-Sample-App@1.0.0
npm info ok 
Preparing build for deployment
Deployment id is 50a96127
Activating deployment
Starting NodeJS cartridge
Success



Expected results:
should not show "hot_deploy marker found." which is confused



Additional info:

after step3, check the deployment list found the hot deploy is false

[root@localhost n10]# rhc deployment list 
Deployment ID 50a96127 (active)
-------------------------------
  Git Reference:     f5b27d3
  SHA1:              f5b27d3
  Created At:        5:24 AM
  Hot Deploy:        false
  Force Clean Build: false
  Activations:       5:25 AM
Comment 1 Andy Goldstein 2013-10-28 09:20:26 EDT

*** This bug has been marked as a duplicate of bug 1022271 ***

Note You need to log in before you can comment on or make changes to this bug.