Bug 1023915 - [RFE]:[PATCH]: Use changelog to provide default update description.
[RFE]:[PATCH]: Use changelog to provide default update description.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedpkg (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 06:27 EDT by Alec Leamas
Modified: 2014-01-25 08:56 EST (History)
4 users (show)

See Also:
Fixed In Version: fedpkg-1.15-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 20:48:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch using clog a default update (2.71 KB, patch)
2013-10-28 06:27 EDT, Alec Leamas
no flags Details | Diff
Patch using clog as default update notes (2.43 KB, patch)
2013-10-29 13:43 EDT, Alec Leamas
no flags Details | Diff

  None (edit)
Description Alec Leamas 2013-10-28 06:27:39 EDT
Created attachment 816758 [details]
Patch using clog a default update

Description of problem:
The current default update description when doing "fedpkg update" is "Here you write the reason for this update" or so. This causes some extra work since the text always must be deleted, and also because the user often has to duplicate the text in the change log in the description


Version-Release number of selected component (if applicable):


How reproducible:always


Steps to Reproduce:
1. Update a package
2. invoke fedpkg update
3.

Actual results:
The description field has a useless default value.


Expected results:
The default value should be taken from changelog.


Additional info:
The patch uses the clog created by the update, If it's just one line, it's used as the default description. If more than one line, these lines are presented
for the user user so she can copy-paste from them when doing the update.
Comment 1 Alec Leamas 2013-10-29 13:43:53 EDT
Created attachment 817147 [details]
Patch using clog as default update notes

Oops, first patch was not OK. Sorry.
Comment 2 Fedora Update System 2013-12-15 20:18:32 EST
fedpkg-1.15-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedpkg-1.15-1.el6
Comment 3 Fedora Update System 2013-12-15 20:19:58 EST
fedpkg-1.15-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedpkg-1.15-1.fc19
Comment 4 Fedora Update System 2013-12-15 20:21:07 EST
fedpkg-1.15-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedpkg-1.15-1.fc20
Comment 5 Fedora Update System 2013-12-16 02:05:16 EST
Package fedpkg-1.15-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedpkg-1.15-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23442/fedpkg-1.15-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-12-19 20:48:40 EST
fedpkg-1.15-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Vít Ondruch 2014-01-02 08:57:49 EST
This is wonderful! Alec, thank you for the patch.
Comment 8 Alec Leamas 2014-01-02 09:51:00 EST
Thanks. That said, the credits should rightfully go to the great rpmfusion people - I've just imported their workflow into fedpkg.
Comment 9 Fedora Update System 2014-01-18 13:18:37 EST
fedpkg-1.15-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2014-01-25 08:56:17 EST
fedpkg-1.15-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.