Bug 1023918 - Nautilus cannot browse windows network when firewalld is on
Nautilus cannot browse windows network when firewalld is on
Status: CLOSED DUPLICATE of bug 1038959
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 06:39 EDT by Rémi G.
Modified: 2013-12-19 13:18 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 13:18:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rémi G. 2013-10-28 06:39:12 EDT
Hi,

- Description of problem:

I cannot browser the windows/samba shares of my local network using Nautilus, but I can when deactivating the firewall.

- Version-Release number of selected component (if applicable):

I'm using an up-to-date version of the upcoming Fedora 20 release. I'm just an end user, so I don't know which component is really concerned:
   nautilus 3.10.0-1.fc20
   samba-client 2:4.1.0-2.fc20
   gvfs-smb 1.18.2-1.fc20
   firewalld 0.3.7-1.fc20 

- How reproducible:

You can use a daily live disk of Fedora 20. With a live disk of Fedora 19, everything works as expected.

- Steps to Reproduce:

1. Open Nautilus
2. Click on "Browse Network" in the left panel
3. Select "Windows Network"

- Actual results:

A dialog pops up saying:
  "Unable to access location
   Failed to retrieve share list from server: No such file or directory"

- Expected results:

Nautilus should display the windows/samba shares of my network.

- Additional info:

If I deactivate the firewall, I can browse the windows network:
  "sudo systemctl stop firewalld.service"

Hope that helps,

Rémi.
Comment 1 Garrett Mitchener 2013-10-31 13:04:22 EDT
I'm apparently seeing the same thing with webdav and nautilus on Fedora 19:

https://ask.fedoraproject.org/question/34950/problem-connecting-to-a-webdav-server-with-nautilus-fedora-19/

I'm trying to connect to a webdav server. When I use Thunar in XFCE, I can type the URL

davs://<my-user-name>@<server>/content/etc.

and it asks me for a password, then connects and lets me see my files. So I know I've got the right password and URL, and the server is doing what I think it's doing.

However, when I try the same with Nautilus, it asks for a password, then gnome shell (I think) dims the desktop and asks for a password, and whatever I type, it doesn't work, and it asks for the password again and again ... and there's nothing I can do to make it work. Eventually I give up and hit cancel, and get an error message about how HTTP was canceled.

When I stop firewalld, nautilus can connect to the webdav server.  When I start it again, nautilus can't connect.  Thunar can connect either way.

My RPMS:

nautilus-3.8.2-1.fc19.x86_64
firewalld-0.3.7-1.fc19.noarch
Comment 2 Garrett Mitchener 2013-10-31 13:27:39 EDT
Or maybe not: I'm seeing more complicated behavior.  I did get nautilus to connect with firewalld running.  Not sure what happened.
Comment 3 Dale Turner 2013-12-02 11:49:47 EST
I am experiencing this behaviour as well in F20.
Comment 4 George Gibbs 2013-12-16 19:11:58 EST
Same issue here on F20.
Comment 5 jake pennell 2013-12-19 12:17:39 EST
I have fedora 20 and am having the same issue.
Comment 6 Filippo Racca 2013-12-19 13:15:27 EST
Same issue here. Enabling samba and samba-client in firewalld doesn't resolve the problem. Neither opening manually the desired ports (137-139 udp and tcp).

firewalld version: 0.3.8-1
Comment 7 Michael Cronenworth 2013-12-19 13:18:21 EST

*** This bug has been marked as a duplicate of bug 1038959 ***

Note You need to log in before you can comment on or make changes to this bug.