Bug 1023920 - FSResizeError: ('resize failed: 1', '/dev/sda2')
FSResizeError: ('resize failed: 1', '/dev/sda2')
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:0f469efe291771c4c9d8ee098c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 06:43 EDT by rakesh
Modified: 2014-02-28 18:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-28 18:02:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (887.70 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: anaconda.log (35.88 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: environ (518 bytes, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: lsblk_output (2.32 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: messages (279.58 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: nmcli_dev_list (3.37 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: os_info (179 bytes, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: program.log (111.47 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: storage.log (441.48 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details
File: ifcfg.log (1.56 KB, text/plain)
2013-10-28 06:44 EDT, rakesh
no flags Details

  None (edit)
Description rakesh 2013-10-28 06:43:51 EDT
Version-Release number of selected component:
anaconda-19.30.13-1.fc19.i686

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 452, in doResize
    raise FSResizeError("resize failed: %s" % ret, self.device)
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 595, in execute
    self.device.format.doResize()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
FSResizeError: ('resize failed: 1', '/dev/sda2')

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-i686-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.i686
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 rakesh 2013-10-28 06:44:01 EDT
Created attachment 816760 [details]
File: anaconda-tb
Comment 2 rakesh 2013-10-28 06:44:06 EDT
Created attachment 816761 [details]
File: anaconda.log
Comment 3 rakesh 2013-10-28 06:44:10 EDT
Created attachment 816762 [details]
File: environ
Comment 4 rakesh 2013-10-28 06:44:17 EDT
Created attachment 816763 [details]
File: lsblk_output
Comment 5 rakesh 2013-10-28 06:44:23 EDT
Created attachment 816764 [details]
File: messages
Comment 6 rakesh 2013-10-28 06:44:27 EDT
Created attachment 816765 [details]
File: nmcli_dev_list
Comment 7 rakesh 2013-10-28 06:44:30 EDT
Created attachment 816766 [details]
File: os_info
Comment 8 rakesh 2013-10-28 06:44:35 EDT
Created attachment 816767 [details]
File: program.log
Comment 9 rakesh 2013-10-28 06:44:41 EDT
Created attachment 816768 [details]
File: storage.log
Comment 10 rakesh 2013-10-28 06:44:45 EDT
Created attachment 816769 [details]
File: ifcfg.log
Comment 11 David Shea 2014-02-28 18:02:53 EST
There is a problem with your drive:

Oct 28 16:03:22 localhost program: ntfsresize v2013.1.13 (libntfs-3g)
Oct 28 16:03:22 localhost program: Device name        : /dev/sda2
Oct 28 16:03:22 localhost program: NTFS volume version: 3.1
Oct 28 16:03:22 localhost program: Cluster size       : 4096 bytes
Oct 28 16:03:22 localhost program: Current volume size: 240046567936 bytes (240047 MB)
Oct 28 16:03:22 localhost program: Current device size: 240046571520 bytes (240047 MB)
Oct 28 16:03:22 localhost program: New volume size    : 212576993792 bytes (212577 MB)
Oct 28 16:03:22 localhost program: ERROR: This software has detected that the disk has at least 1 bad sector.
Oct 28 16:03:22 localhost program: ****************************************************************************
Oct 28 16:03:22 localhost program: * WARNING: The disk has bad sector. This means physical damage on the disk *
Oct 28 16:03:22 localhost program: * surface caused by deterioration, manufacturing faults or other reason.   *
Oct 28 16:03:22 localhost program: * The reliability of the disk may stay stable or degrade fast. We suggest  *
Oct 28 16:03:22 localhost program: * making a full backup urgently by running 'ntfsclone --rescue ...' then   *
Oct 28 16:03:22 localhost program: * run 'chkdsk /f /r' on Windows and rebooot it TWICE! Then you can resize  *
Oct 28 16:03:22 localhost program: * NTFS safely by additionally using the --bad-sectors option of ntfsresize.*
Oct 28 16:03:22 localhost program: ****************************************************************************

Note You need to log in before you can comment on or make changes to this bug.