Bug 1023944 - Document how to change MySQL character set configuration
Document how to change MySQL character set configuration
Status: CLOSED NEXTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Documentation (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Julie
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 08:09 EDT by Hiro Asari
Modified: 2015-07-19 19:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-03 20:04:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiro Asari 2013-10-28 08:09:05 EDT
Description of problem:
Describe how to change MySQL character set for the session.

Bug 1010582 describes how to change MySQL instance's character set with action hooks, application configurations, etc.
Comment 3 Luke Meyer 2014-02-24 09:05:59 EST
It's a request for enhancement/clarification. And yes, I'd say it's legitimate; it's an instance where using something (MySQL) under OpenShift is not as straightforward as people are used to when running it independently and having full control over the configuration. Our answer in this case seems to be that really, it's something your DB client usage should specify anyway. Although it's possible to specify the setting globally in a git action hook, that doesn't seem like a good recommendation to make.

I'm not sure at this time where exactly in the user guide this should go. If there's a section for MySQL-specific notes, then some mention of the the need for the client to specify character set, with a reference to bug 1010582 would be a good addition.
Comment 12 Julie 2014-04-03 20:04:41 EDT
updates already published in Online User Guide.
Enterprise User Guide pending next release.

Note You need to log in before you can comment on or make changes to this bug.