Bug 1023963 - failure to mount storage domain should be faster and with a clear error message
failure to mount storage domain should be faster and with a clear error message
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity low
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 09:02 EDT by Yedidyah Bar David
Modified: 2013-12-05 05:49 EST (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.8.beta3.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 06:11:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20877 None None None Never
oVirt gerrit 20903 None None None Never

  None (edit)
Description Yedidyah Bar David 2013-10-28 09:02:47 EDT
Description of problem:

When running 'hosted-engine --deply' and providing an nfs export that fails to mount, it takes a long time, and exits with a non-helpful message.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. hosted-engine --deploy
2. Provide a shared storage path that is inaccessible, e.g. blocked in the firewall

Actual results:

After more than 2 minutes of trying, it fails with:
[ ERROR ] Failed to execute stage 'Environment customization': The read operation timed out

Expected results:

Should give up faster, with the error from the failed mount command.

Additional info:
Comment 1 Sandro Bonazzola 2013-10-28 09:36:44 EDT
(In reply to Yedidyah Bar David from comment #0)
> Description of problem:
> 
> When running 'hosted-engine --deply' and providing an nfs export that fails
> to mount, it takes a long time, and exits with a non-helpful message.
> 
> Version-Release number of selected component (if applicable):
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1. hosted-engine --deploy
> 2. Provide a shared storage path that is inaccessible, e.g. blocked in the
> firewall
> 
> Actual results:
> 
> After more than 2 minutes of trying, it fails with:

this can be reduced by using -otimeo in mount command line (defaults to 60 seconds). how many seconds should we use as timeout here? May 10 be enough? (with 1 re-transmission it's 20 seconds in total)

> [ ERROR ] Failed to execute stage 'Environment customization': The read
> operation timed out

Ok

> 
> Expected results:
> 
> Should give up faster, with the error from the failed mount command.
> 
> Additional info:
Comment 2 Yedidyah Bar David 2013-10-29 06:19:44 EDT
(In reply to Sandro Bonazzola from comment #1)
> > After more than 2 minutes of trying, it fails with:
> 
> this can be reduced by using -otimeo in mount command line (defaults to 60
> seconds). how many seconds should we use as timeout here? May 10 be enough?
> (with 1 re-transmission it's 20 seconds in total)

I think it's 'retry=' . Agree about 20 seconds - might make sense to be settable by the environment.
Comment 3 Sandro Bonazzola 2013-11-04 10:12:05 EST
(In reply to Yedidyah Bar David from comment #2)
> I think it's 'retry=' . Agree about 20 seconds - might make sense to be
> settable by the environment.

You're right it's retry, it accepts only minutes and defaults to 2.
We can reduce it to 1 minute.
Comment 4 Sandro Bonazzola 2013-11-05 05:09:53 EST
Patches merged on upstream master and 1.0 branches.
Comment 6 Charlie 2013-11-27 20:19:00 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 Sandro Bonazzola 2013-12-05 05:49:44 EST
hosted engine is a new package, does not need errata for specific bugs during its development.

Note You need to log in before you can comment on or make changes to this bug.