Bug 1023965 - HA agent might fail to work correctly due to incorrect path to the Gluster storage domain.
HA agent might fail to work correctly due to incorrect path to the Gluster st...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Greg Padgett
Artyom
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 09:07 EDT by Leonid Natapov
Modified: 2016-06-12 19:16 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-ha-0.1.0-0.4.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 11:13:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20631 None None None Never

  None (edit)
Description Leonid Natapov 2013-10-28 09:07:56 EDT
HA agent might fail to work correctly due to incorrect path to the Gluster storage domain. NFS storage domain path is differs from Gluster FS storage domain path. It seems like HA agent doesn't take it into consideration which might cause it to fail work correctly.

Instructions for QA:
Quick HA sanity while working with GlusterFS storage.
Comment 1 Greg Padgett 2013-10-29 08:31:08 EDT
Merged Change-Id: I7838e373d1cbe0682bfbffa697e6cd5eff819308
Comment 3 Artyom 2013-10-30 14:04:24 EDT
Please provide version that include fix
Comment 4 Sandro Bonazzola 2013-11-22 05:17:47 EST
Well, it is true that hosted-engine-setup is actually allowing only NFS storage, but this specific bug is fixed in ovirt-hosted-engine-ha-0.1.0-0.4.beta1.el6ev.
Not sure that wontfix is correct status.
Comment 5 Artyom 2013-11-24 01:02:05 EST
I talk with Doron, and he said that in near future hosted engine will not support gluster, because some serious bug in gluster himself, so when gluster support will be enable I will open bug to check hosted engine sanity on gluster storage.
Comment 6 Sandro Bonazzola 2013-11-25 03:27:30 EST
(In reply to Artyom from comment #5)
> I talk with Doron, and he said that in near future hosted engine will not
> support gluster, because some serious bug in gluster himself, so when
> gluster support will be enable I will open bug to check hosted engine sanity
> on gluster storage.

ok
Comment 7 Charlie 2013-11-27 20:42:11 EST
This bug is currently attached to errata RHEA-2013:15591. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 Greg Padgett 2013-12-06 12:56:22 EST
ovirt-hosted-engine-ha is a new package; does not need errata for bugs during its development.

Note You need to log in before you can comment on or make changes to this bug.