This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1023974 - Moving a directory with content, into a directory where there is no quota left, succeeds
Moving a directory with content, into a directory where there is no quota lef...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 09:26 EDT by krishnan parthasarathi
Modified: 2015-11-03 18:05 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:50:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2013-10-28 09:26:19 EDT
Description of problem:

Moving a directory with content, into a directory where there is no quota left, succeeds.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a gluster distributed-replicate volume
2. Set quota on a directory on the volume (using fuse mount), e.g: 1GB
3. Create a sub-directory in the directory and set same quota on it.
4. Mount the volume on a Win7 client.
5. Run IO till you reach quota,
6. Create a directory (outside of the directory on which quota is set) and create files in it (run file IO)
7. Now move the directory to the directory whose quota is already reached to limit.


Actual results:

Directory with files can be moved successfully to the directory whose quota is already reached to limit

Expected results:

Step #7 should fail

Additional info:
Comment 1 Anand Avati 2013-10-28 09:50:12 EDT
REVIEW: http://review.gluster.org/6155 (quota: get directory size before enforcing quota limits on rename) posted (#1) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 2 Anand Avati 2013-10-28 12:38:10 EDT
REVIEW: http://review.gluster.org/6155 (quota: get directory size before enforcing quota on rename) posted (#2) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 3 Anand Avati 2013-12-23 00:29:43 EST
REVIEW: http://review.gluster.org/6155 (quota: get directory size before enforcing quota on rename) posted (#3) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 4 Anand Avati 2014-01-20 05:14:58 EST
REVIEW: http://review.gluster.org/6155 (quota: get directory size before enforcing quota on rename) posted (#4) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 5 Anand Avati 2014-01-20 10:15:23 EST
COMMIT: http://review.gluster.org/6155 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 17c4fb2d04f84b5632983866e8bddfbd7d77a054
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Mon Oct 28 19:14:49 2013 +0530

    quota: get directory size before enforcing quota on rename
    
    Change-Id: If18cab5992ddc91457782786942971deb1b51ead
    BUG: 1023974
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/6155
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Anand Avati 2014-02-02 20:22:43 EST
REVIEW: http://review.gluster.org/6887 (quota: get directory size before enforcing quota on rename) posted (#1) for review on release-3.5 by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 7 Anand Avati 2014-02-03 21:59:27 EST
REVIEW: http://review.gluster.org/6887 (quota: get directory size before enforcing quota on rename) posted (#2) for review on release-3.5 by Krishnan Parthasarathi (kparthas@redhat.com)
Comment 8 Anand Avati 2014-02-06 02:06:41 EST
COMMIT: http://review.gluster.org/6887 committed in release-3.5 by Vijay Bellur (vbellur@redhat.com) 
------
commit f0fac871dc32f0d3756c84c22b7f9b0a6b3daec5
Author: Krishnan Parthasarathi <kparthas@redhat.com>
Date:   Mon Oct 28 19:14:49 2013 +0530

    quota: get directory size before enforcing quota on rename
    
            Backport of http://review.gluster.org/6155
    
    BUG: 1023974
    Change-Id: Icb4bca8c4a5fa9b14855478e69b1315f2e9a3c3d
    Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Reviewed-on: http://review.gluster.org/6887
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 9 Niels de Vos 2014-04-17 07:50:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.