Bug 1023999 - startkde adding /bin to $PATH
startkde adding /bin to $PATH
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 10:38 EDT by T.C. Hollingsworth
Modified: 2013-10-28 16:36 EDT (History)
10 users (show)

See Also:
Fixed In Version: kde-workspace-4.11.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 10:48:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description T.C. Hollingsworth 2013-10-28 10:38:17 EDT
Looks like this snippet in startkde is adding /bin to $PATH:

bindir=`echo "$0" | sed -n 's,^\(/.*\)/[^/][^/]*$,\1,p'`
if [ -n "$bindir" ]; then
  qbindir=`$bindir/kde4-config --qt-binaries`
  qdbus=$qbindir/qdbus
    $bindir|$bindir:*|*:$bindir|*:$bindir:*) ;;
    *) PATH=$bindir:$PATH; export PATH;;

I added an `echo $bindir > /tmp/bindir` and restarted KDE to make sure.

Might be where this is coming from:
https://lists.fedoraproject.org/pipermail/devel/2013-October/190776.html

Please patch startkde not to do this, it confuses some applications (and users) and is rather undesirable in the post-UsrMove universe.  Thanks!
Comment 1 Rex Dieter 2013-10-28 10:48:06 EDT
yeah, I think we can assume qdbus is in $PATH already.

%changelog
* Mon Oct 28 2013 Rex Dieter <rdieter@fedoraproject.org> 4.11.2-3
- startkde adding /bin to $PATH (#1023999)

Fix will be rolled into 4.11.3 updates coming soon.
Comment 2 Kevin Kofler 2013-10-28 16:32:42 EDT
Why is this crap snippet AGAIN in our startkde? We were always patching that out (in past upstream incarnations, it would not add /bin, but the path containing the unsuffixed assistant etc., breaking the Qt 3 .desktop files), the hunk patching it out had already gone lost at least once and I had readded it. Please do not randomly drop hunks of our patches when rebasing patches, they are all there for a reason!
Comment 3 Kevin Kofler 2013-10-28 16:36:03 EDT
(I'm starting to think that instead of that startkde patch that needs constant rebasing, we should just ship a cleaned startkde we control as a Source* and use that to replace the upstream junk-loaded script wholesale.)

Note You need to log in before you can comment on or make changes to this bug.