Bug 1024008 - Disabling windows live mail from gnome-online-accounts doesn't remove it from Evolution.
Disabling windows live mail from gnome-online-accounts doesn't remove it from...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 10:54 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-11-05 06:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 05:31:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
goa with disabled windows live account (42.22 KB, image/png)
2013-10-28 10:54 EDT, Ankur Sinha (FranciscoD)
no flags Details
showing evolution with account still showing even after disabling (78.71 KB, image/png)
2013-10-28 10:55 EDT, Ankur Sinha (FranciscoD)
no flags Details
evolution preferences showing account still in list (9.86 KB, image/png)
2013-10-28 10:56 EDT, Ankur Sinha (FranciscoD)
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 711472 None None None Never

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-10-28 10:54:37 EDT
Created attachment 816826 [details]
goa with disabled windows live account

Description of problem:
I set up windows live using GOA. Windows live doesn't work, but that's a different bug. I disabled windows live mail from GOA and used imap/smtp to access my mail. Even though it's disabled in goa, the mail account still shows up in Evolution.

Toggling it for gmail works just fine. 

Version-Release number of selected component (if applicable):
[asinha@ankur-laptop  fedora-appstream(master=)]$ rpm -q gnome-online-accounts
gnome-online-accounts-3.10.1-2.fc20.x86_64
[asinha@ankur-laptop  fedora-appstream(master=)]$ rpm -q evolution
evolution-3.10.1-1.fc20.x86_64
[asinha@ankur-laptop  fedora-appstream(master=)]$

How reproducible:
Always.

Steps to Reproduce:
1. Add windows live accounts
2. Disable mail in goa
3. check evolution

Actual results:
Account still shows

Expected results:
Account shouldnt show

Additional info:
Is it possible that the email erring out is causing the account to stick around for some reason? 

I can file this upstream if someone verifies it.

Thanks,
Warm regards,
Ankur
Comment 1 Ankur Sinha (FranciscoD) 2013-10-28 10:55:36 EDT
Created attachment 816827 [details]
showing evolution with account still showing even after disabling
Comment 2 Ankur Sinha (FranciscoD) 2013-10-28 10:56:12 EDT
Created attachment 816829 [details]
evolution preferences showing account still in list
Comment 3 Milan Crha 2013-11-05 05:31:16 EST
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=711472
Comment 4 Ankur Sinha (FranciscoD) 2013-11-05 06:03:59 EST
Thanks Milan. CC'd myself to the upstream report.

Note You need to log in before you can comment on or make changes to this bug.