Bug 1024010 - [RFE] Report guests Buffered/Cached memory
[RFE] Report guests Buffered/Cached memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
All Linux
medium Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
: FutureFeature
Depends On: 1024007
Blocks: 1203189 1209910
  Show dependency treegraph
 
Reported: 2013-10-28 10:57 EDT by Amador Pahim
Modified: 2016-03-09 15:33 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
A virtual machine's buffered or cached memory is now taken into account in the Extract, Transform and Load (ETL) process. Some applications, like the Oracle Directory Server, uses cached memory as permanent memory and never releases it. As a result, users need to take this memory into account when planning for memory requirements. The data is collected each minute, hour and day as a default and users can create ad hoc reports based on the collected data.
Story Points: ---
Clone Of:
: 1203189 (view as bug list)
Environment:
Last Closed: 2016-03-09 15:33:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 35954 master MERGED Report guest free/buffered/cached memory Never
oVirt gerrit 41946 master MERGED db: Fix size of guest memory information from INTEGER => BIGINT Never

  None (edit)
Description Amador Pahim 2013-10-28 10:57:04 EDT
Some applications, like Oracle Directory Server, use cached memory and never release it. Users need to take this memory into account when planning the memory requirements.
Please report guests Buffered/Cached memory in addition to used memory, currently reported as a percent bar.
I'd suggest to add a field in Guest General sub-tab with "Free: X, Buffered: Y, Cached: Z."
Comment 1 Michal Skrivanek 2014-06-13 10:16:27 EDT
added way after 3.5 dates.
moving out, please bring up for future release planning sessions
Comment 4 Jiri Belka 2015-04-17 12:38:07 EDT
ok, ovirt-engine-webadmin-portal-3.6.0-0.0.master.20150412172306.git55ba764.el6.noarch / rhevm-guest-agent-common-1.0.10-2.el6ev

Guest OS Memory Free/Cached/Buffered: 871 / 12 / 132 MB

# vdsClient -s 0 getAllVmStats | grep mem_
        memoryStats = {'swap_out': '0', 'majflt': '0', 'swap_usage': '0', 'mem_cached': '135756', 'mem_free': '892496', 'mem_buffers': '12808', 'swap_in': '0', 'swap_total': '2097148', 'pageflt': '0', 'mem_total': '1018504', 'mem_unused': '743932'}
Comment 7 errata-xmlrpc 2016-03-09 15:33:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.