Bug 1024040 - Change Installer Flow to Improve Useability
Change Installer Flow to Improve Useability
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: ER7
: 6.0.0
Assigned To: Francisco Canas
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 12:25 EDT by Francisco Canas
Modified: 2014-02-06 10:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francisco Canas 2013-10-28 12:25:10 EDT
Description of problem:
The order in which the Installer panel flows should be changed to reflect suggestions on improving useability from the UX meeting on Oct 22nd.

Suggested Order of Panels (after License is displayed):
1) Pack Selection
2) Target Path Selection
3) "post-install" configuration selection
- Optionally followed by selected post-install elements
4) Admin User Creation
- Optionally followed by user account creation for any needed extra accounts: BPEL user account, Governance Credentials, etc.
5) DB Configuration Panel
6) Installation Panel
7) Post-installation/Configuration Processing
9) Finish Panel
Comment 2 Francisco Canas 2013-10-29 09:52:24 EDT
Installer flow has been restructured according to UX suggestions:

See:
http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?id=9580aa076444c397d602089d2bd864db953dfc69

Note:
Due to limitations in IZpack design, having the pack selection panel right at the very beginning causes complications with installation of EAP pack. EAP will get installed regardless of whether it already exists or not in the target directory. Will need to modify IZpack to allow changing packs after selection panel is run.
Comment 3 Len DiMaggio 2013-11-11 12:14:51 EST
Francisco - can you set the severity value for this bugzilla? Thanks!
Comment 4 Thomas Hauser 2013-12-13 12:50:11 EST
These changes have been implemented, as well as modified again as per further discussion. The ER7-2 installer contains the final implementation of these suggestions. Any further modifications should be discussed here.
Comment 5 Len DiMaggio 2014-01-03 14:29:52 EST
Verified in ER8.

Note You need to log in before you can comment on or make changes to this bug.