Bug 1024076 - new thin lv names are not checked against already in-use names
new thin lv names are not checked against already in-use names
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20BetaBlocker 1027375
  Show dependency treegraph
 
Reported: 2013-10-28 14:26 EDT by Chris Murphy
Modified: 2013-11-08 23:25 EST (History)
6 users (show)

See Also:
Fixed In Version: python-blivet-0.23.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1027375 (view as bug list)
Environment:
Last Closed: 2013-11-08 23:25:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-tb (617.35 KB, text/plain)
2013-10-28 14:28 EDT, Chris Murphy
no flags Details
anaconda.log (75.37 KB, text/plain)
2013-10-28 14:28 EDT, Chris Murphy
no flags Details
program.log (51.71 KB, text/plain)
2013-10-28 14:30 EDT, Chris Murphy
no flags Details
storage.log (272.40 KB, text/plain)
2013-10-28 14:31 EDT, Chris Murphy
no flags Details
anaconda-tb comment 6 crash (650.65 KB, text/plain)
2013-10-28 17:33 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-10-28 14:26:59 EDT
Originally abrt dinged bug 1021507 with this.

Description of problem: When creating a thinpool LV with the same name as existing, I get a crash; by default for thinpool LV's, the installer isn't checking for existing names and can propose a default name for a new LV for an existing LV of the same name thus running into the crash.


Version-Release number of selected component (if applicable):
anaconda-20.25.4-1


How reproducible:
Always when new name = existing name, but so far only with Thin Provisioning does this happen by default.

Steps to Reproduce:
1. Minimal package set install to single disk, single LVM Thin Provisioning via Guided path.
2. Reboot to installer, custom path.
3. Remove existing fedora-home LV.
4. Reuse existing fedora-swap LV.
5. Create new mount point / without size value.
[I note that it makes the name of the LV "root" which is the same as existing LV.]
6. Begin installation.

Actual results:
Crash.

Expected results:
Error message about the conflicting new and existing names instead of crash.
LVM thin provisioning should check existing name and propose a non-conflicting name, which is how conventional LVM works.

Additional info:
Comment 1 Chris Murphy 2013-10-28 14:28:10 EDT
Created attachment 816872 [details]
anaconda-tb
Comment 2 Chris Murphy 2013-10-28 14:28:25 EDT
Created attachment 816873 [details]
anaconda.log
Comment 3 Chris Murphy 2013-10-28 14:30:51 EDT
Created attachment 816874 [details]
program.log
Comment 4 Chris Murphy 2013-10-28 14:31:03 EDT
Created attachment 816875 [details]
storage.log
Comment 5 David Lehman 2013-10-28 15:35:03 EDT
Here's a link to an updates image that should fix this problem:

  http://dlehman.fedorapeople.org/updates/updates-1024076.0.img

Please report back with results.
Comment 6 Chris Murphy 2013-10-28 17:31:02 EDT
With updates image applied, adding a new root LV as device LVM Thin Provisioning, the problem doesn't occur in that the new / is named root00. If I try to intentionally change it to root, it snaps back to root00.

However when I go to begin installation, I get a crash. Will attach logs.
Comment 7 Chris Murphy 2013-10-28 17:33:05 EDT
Created attachment 816929 [details]
anaconda-tb comment 6 crash

DeviceCreateError: ('lvcreate failed for fedora/pool00: running lvm lvcreate --thinpool fedora/pool00 --size 67844m failed', 'fedora-pool00')

It's trying to create an existing thinpool with the same name. So maybe it's a different bug. Annoying that abrt keeps dinging 1021507 with these.
Comment 8 David Lehman 2013-10-28 19:00:12 EDT
Please open a new bug report for the new bug reported in comments 6&7.
Comment 9 Chris Murphy 2013-10-28 19:02:45 EDT
So the secondary crash with updates image as reported in c6/c7 is transient.

I started over with a new qcow2 file and went through the reproduce steps in the description exactly, except I applied the update image. And this time around it installs without a crash. The disk storage state was messy for c6/c7, because some storage modifications were occurring at the time of the crash.
Comment 10 Chris Murphy 2013-10-28 20:24:08 EDT
Attempting to reproduce bug in comment 6&7 but so far I get new bug 1024144.
Comment 11 Mike Ruckman 2013-10-30 13:27:23 EDT
Discussed in 2013-10-30 Blocker Review Meeting [1]. It was voted as an AcceptedBlocker. Blocker status was moved from 1021507 [2] to this bug.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-30/
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1021507
Comment 12 Chris Murphy 2013-10-30 19:29:27 EDT
Bug is fixed, marking as verified, remaining crash discussed in bug 1024144.


Clarified steps, attempting to reproduce this bug with the updates.img:
1. Minimal package set install to single disk, single LVM Thin Provisioning via Guided path.
2. Reboot to installer, with comment 5 updates.img applied, custom partition path, with Partition Scheme pop-up set to LVM Thin Provisioning.
3. Remove existing fedora-home LV.
4. Reuse existing fedora-swap LV.
4. Reuse existing /boot by reformatting.
6. Create new mount point / without size value.
7. Begin installation.
Succeeds and is bootable.

This bug was about new thinp LV's by default named the same as existing, then crashing, and that's no longer happening with updates.img: new LV is named differently by default, and even if I try to intentionally name it the same as existing, I'm thwarted. Thus, this is fixed.
Comment 13 Fedora Update System 2013-11-06 14:02:14 EST
python-blivet-0.23.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-blivet-0.23.4-1.fc20
Comment 14 Fedora Update System 2013-11-08 23:25:28 EST
python-blivet-0.23.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.