Bug 1024078 - openstack-neutron needs a versioned requires: on python-oslo-config
openstack-neutron needs a versioned requires: on python-oslo-config
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: beta
: 4.0
Assigned To: Terry Wilson
Roey Dekel
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 14:29 EDT by Lars Kellogg-Stedman
Modified: 2016-04-26 09:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-5.el6ost
Doc Type: Bug Fix
Doc Text:
When upgrading the Networking service from Quantum to Neutron, the python-oslo-config package from Red Hat OpenStack 3 originally satisfied openstack-neutron package dependencies. However, this version of python-oslo-config did not provide classes and methods required by Neutron. As a result, upgrading the Networking service in this manner could prevent it from working properly. With this update, openstack-neutron packages are now specifically dependent on the python-oslo-config version provided with Red Hat OpenStack 4. This version provides all the classes and methods required by Neutron.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:33:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2013-10-28 14:29:40 EDT
Description of problem:

If you upgrade from quantum to neutron, the python-oslo-config package from RHOS 3 will satisfy dependency from the openstack-neutron pacakges.  Unfortunately, python-oslo-config-1.1.0 is missed classes and methods required by the neutron package.s


Version-Release number of selected component (if applicable):

openstack-neutron-2013.2-3.el6ost.noarch

How reproducible:

On a system running Quantum (and no other OpenStack services):

yum install openstack-neutron

Complete the upgrade, then attempt to run, e.g., neutron-db-manage.
Comment 4 Scott Lewis 2013-11-18 15:35:36 EST
Adding to beta milestone for MODIFIED/ON-QA bugs
Comment 5 Ofer Blaut 2013-11-20 05:07:42 EST


[root@puma04 ~]# rpm -qR openstack-neutron-2013.2-9.el6ost.noarch
/bin/bash  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/bin/sh  
/usr/bin/python  
chkconfig  
chkconfig  
config(openstack-neutron) = 2013.2-9.el6ost
dnsmasq  
dnsmasq-utils  
initscripts  
initscripts  
openstack-utils  
python-keystone  
python-neutron = 2013.2-9.el6ost
python-pbr  
python-pyudev  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
shadow-utils  
rpmlib(PayloadIsXz) <= 5.2-1
[root@puma04 ~]# rpm -qR python-neutron-2013.2-9.el6ost.noarch
MySQL-python  
python(abi) = 2.6
python-alembic  
python-anyjson  
python-babel  
python-eventlet  
python-greenlet  
python-httplib2  
python-iso8601  
python-jinja2-26  
python-keystoneclient  
python-lxml  
python-netaddr  
python-neutronclient  
python-oslo-config >= 1:1.2.0
python-paste-deploy1.5  
python-qpid  
python-routes1.12  
python-sqlalchemy0.7  
python-webob1.0  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
sudo  
rpmlib(PayloadIsXz) <= 5.2-1
[root@puma04 ~]# rpm -qa | grep oslo
python-oslo-config-1.2.1-1.el6ost.noarch
Comment 7 errata-xmlrpc 2013-12-19 19:33:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.