Bug 1024083 - Evolution forgets google application-specific password for Gmail IMAP
Evolution forgets google application-specific password for Gmail IMAP
Status: CLOSED DUPLICATE of bug 977720
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 14:46 EDT by Bryan Mason
Modified: 2013-11-05 06:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 06:00:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Mason 2013-10-28 14:46:44 EDT
Description of problem:

    Evolution keeps forgetting my IMAP password for GMail.  I have
    two-factor authentication enabled for Google, so I'm using
    application-specific passwords.

Version-Release number of selected component (if applicable):

    evolution-3.8.5-2.fc19.x86_64
    evolution-ews-3.8.5-3.fc19.x86_64
    evolution-data-server-3.8.5-5.fc19.x86_64

How reproducible:

    Eventually, 100%

Steps to Reproduce:

    1. Create an application-specific password and enter it into the
       system-model (yuck!) dialog that prompts for a password for
       imap.gmail.com.

    2. Create a new application-specific password (or re-use the one
       created in step 1) and enter it when prompted for
       smtp.gmail.com

Actual results:

    Eventually, Evolution will prompt for the password to check
    imap.gmail.com.

Expected results:

    The password should be remembered.

Additional info:

  * I have not used the Online Accounts feature of GNOME, so I don't
    think this is an instance of Bug 977720.

  * I also have Google Contacts and Google Calendar configured in
    Evolution with application-specific passwords.  Neither of those
    seem to be having any problems.

  * If I open Seahorse (seahorse-3.8.2-1.fc19.x86_64) and filter on
    "evolution", I see four entries related to Google.  Two of them
    are numbered "1380061929.22542.6@<hostname>" and
    "1380061929.22542.16@<hostname>".  The ".6" entry keeps on
    disappearing whenever Evolution prompts for the password, and gets
    created after I enter a password.  I believe the ".6" entry is for
    IMAP and the ".16" entry is for SMTP.

  * Sometimes, re-using the password that I've created for IMAP works,
    but eventually it fails.

  * I've tried using the same password for IMAP and SMTP, and I've
    tried using different passwords for IMAP and SMTP.  Doesn't seem
    to make a difference.
Comment 1 Milan Crha 2013-11-05 06:00:30 EST
Thanks for a bug report. The bug #977720 wasn't about Gnome-Online-Accounts (GOA), not completely. The same bug can be reproduced without GOA, only by checking at the end to add also contacts/calendar (you can add these separately later too). See bug #977720 comment #21 for more info.

*** This bug has been marked as a duplicate of bug 977720 ***

Note You need to log in before you can comment on or make changes to this bug.