Bug 10241 - RHL 6.1 "bashrc" and "profile" comments.
RHL 6.1 "bashrc" and "profile" comments.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: setup (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-19 14:55 EST by swear
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 09:54:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description swear 2000-03-19 14:55:04 EST
Various "bashrc" & and "profile" files refer to "aliases and functions".
That should instead be "aliases, non-exported functions, and
non-exported variables".

I could go on about the poor shell startup-script scheme (BASH_ENV,
/etc/profile.d, etc.), but I suppose it's a feature, not a bug.
Much of the fault belongs to bash.  They must have worked hard to
make something so simple so confusing, namely to control what
happens at the startup of four combinations of (non-)interactive
and (non-)login shells.  I've got a small "profile" which sets
a couple of variables for "bashrc" and everything else is there
in "exported" and "not exported" sections.
Comment 1 Bernhard Rosenkraenzer 2000-10-10 09:54:03 EDT
/etc/profile etc. belong to the setup package, assigning
Comment 2 Bill Nottingham 2001-01-29 13:16:41 EST
This is not something that I think we'll change ATM.

Note You need to log in before you can comment on or make changes to this bug.