Bug 1024109 - [CCC] (6.3) NPE in DelegatingServerInventory
[CCC] (6.3) NPE in DelegatingServerInventory
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: DR0
: EAP 6.3.0
Assigned To: Brian Stansberry
Petr Kremensky
Lucas Costi
:
Depends On:
Blocks: 1041330
  Show dependency treegraph
 
Reported: 2013-10-28 16:55 EDT by Brian Stansberry
Modified: 2014-06-28 11:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Management requests sent to a Host Controller immediately after the Host Controller had launched may have failed with an exception of type `NullPointerException`. This was because there was a period of time between when the Host Controller was able to receive requests and when the server management system had fully started. This period of time was usually less than one second, but any requests received in that time would fail. This issue has been fixed in this release by making sure that a Host Controller will only receive requests once the server management system has fully started. As a result, there is no longer period of time where received requests will trigger a `NullPointerException` because the the server management system has not fully started.
Story Points: ---
Clone Of:
: 1041330 (view as bug list)
Environment:
Last Closed: 2014-06-28 11:25:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2370 Major Resolved NPE in DelegatingServerInventory 2015-07-10 14:04:25 EDT

  None (edit)
Description Brian Stansberry 2013-10-28 16:55:43 EDT
There's a gap in the HostController boot sequence between when the external management interface services allow connections and when the ServerInventory service used internally by the HC for managing servers is available. If certain management requests that need to find info about servers come in during this window, an NPE occurs:

[Host Controller] 03:26:38,028 ERROR [org.jboss.as.controller.management-operation] (management-handler-thread - 4) JBAS014612: Operation ("read-attribute") failed - address: ([
[Host Controller] ("host" => "failover-h1"),
[Host Controller] ("server-config" => "failover-one")
[Host Controller] ]): java.lang.NullPointerException
[Host Controller] at org.jboss.as.host.controller.DomainModelControllerService$DelegatingServerInventory.determineServerStatus(DomainModelControllerService.java:788)
[Host Controller] at org.jboss.as.host.controller.operations.ServerStatusHandler.execute(ServerStatusHandler.java:66)
[Host Controller] at org.jboss.as.controller.operations.global.ReadAttributeHandler.doExecuteInternal(ReadAttributeHandler.java:177) [wildfly-controller-8.0.0.Beta2-SNAPSHOT.jar:8.0.0.Beta2-SNAPSHOT]
[Host Controller] at org.jboss.as.controller.operations.global.ReadAttributeHandler.doExecute(ReadAttributeHandler.java:97) [wildfly-controller-8.0.0.Beta2-SNAPSHOT.jar:8.0.0.Beta2-SNAPSHOT]
[Host Controller] at org.jboss.as.controller.operations.global.GlobalOperationHandlers$AbstractMultiTargetHandler.execute(GlobalOperationHandlers.java:151) [wildfly-controller-8.0.0.Beta2-SNAPSHOT.jar:8.0.0.Beta2-SNAPSHOT]

This shows up as fairly frequent failures in org.jboss.as.test.integration.domain.DomainControllerMigrationTestCase.testDCFailover. Any kind of automated tooling that started/reloaded/restarted an HC and then started polling for completion of server launch could hit the same issue.
Comment 8 Petr Kremensky 2014-03-04 07:00:06 EST
Verified on EAP 6.3.0.DR1

Note You need to log in before you can comment on or make changes to this bug.